diff mbox series

[bug#65949,18/33] gnu: Add go-github-com-fanliao-go-promise.

Message ID c71b946e8750b0775c13894c71d6a605d1de88da.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-fanliao-go-promise): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:41 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65949@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f2924ae796..7f19cfa608 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13557,6 +13557,31 @@  (define-public go-github-com-mdlayher-packet
      "Package packet provides access to Linux packet sockets (AF_PACKET).")
     (license license:expat)))
 
+(define-public go-github-com-fanliao-go-promise
+  (package
+    (name "go-github-com-fanliao-go-promise")
+    (version "0.0.0-20141029170127-1890db352a72")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fanliao/go-promise")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0nlls86fx6sxsvwp5k769h5knwh96j8fahhivh6fagzjjyyqcijd"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/fanliao/go-promise"
+       ;; The tests fail but I'm too lazy to look into it
+       #:tests? #f))
+    (propagated-inputs (list go-github.com-smartystreets-goconvey))
+    (home-page "https://github.com/fanliao/go-promise")
+    (synopsis "Installation")
+    (description
+     "Package promise provides a complete promise and future implementation.  A quick
+start sample:")
+    (license license:expat)))
 
 (define-public go-github-com-vishvananda-netlink
   (package