diff mbox series

[bug#65939,01/33] gnu: Add go-github-com-sourcegraph-go-lsp.

Message ID f0567ab42922adb73d001fc2ab47892c1057129b.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-sourcegraph-go-lsp): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:28 a.m. UTC | #1
close

help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65939@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
Edouard Klein Sept. 14, 2023, 7:35 a.m. UTC | #2
Edouard Klein <edou@rdklein.fr> writes:

> close
>
> help-debbugs@gnu.org (GNU bug Tracking System) writes:
>
>> Thank you for filing a new bug report with debbugs.gnu.org.
>>
>> This is an automatically generated reply to let you know your message
>> has been received.
>>
>> Your message is being forwarded to the package maintainers and other
>> interested parties for their attention; they will reply in due course.
>>
>> As you requested using X-Debbugs-CC, your message was also forwarded to
>>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
>> (after having been given a bug report number, if it did not have one).
>>
>> Your message has been sent to the package maintainer(s):
>>  guix-patches@gnu.org
>>
>> If you wish to submit further information on this problem, please
>> send it to 65939@debbugs.gnu.org.
>>
>> Please do not send mail to help-debbugs@gnu.org unless you wish
>> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cbd4bafd20..d9914463ff 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -41,6 +41,7 @@ 
 ;;; Copyright © 2022 Christopher Howard <christopher@librehacker.com>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2023 Edouard Klein <edk@beaver-labs.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -13200,6 +13201,29 @@  (define-public go-github-com-google-shlex
 using shell-style rules for quoting and commenting.")
     (license license:asl2.0)))
 
+(define-public go-github-com-sourcegraph-go-lsp
+  (package
+    (name "go-github-com-sourcegraph-go-lsp")
+    (version "0.0.0-20200429204803-219e11d77f5d")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/sourcegraph/go-lsp")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1192qrdlm698z7dsl5i88rk9p31dgx4xq7ljzhn17dl2mynbc2l2"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/sourcegraph/go-lsp"))
+    (home-page "https://github.com/sourcegraph/go-lsp")
+    (synopsis "go-lsp")
+    (description
+     "Package lsp contains Go types for the messages used in the Language Server
+Protocol.")
+    (license license:expat)))
+
 (define-public go-github-com-gorilla-websocket
   (package
     (name "go-github-com-gorilla-websocket")