diff mbox series

[bug#65961,22/33] gnu: Add go-github-com-cilium-ebpf.

Message ID 4405572043ba24623c7b57adba2e9f27eeca54f2.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-cilium-ebpf): New variable.
---
 gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:46 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65961@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c55fcde5fc..041c14a9cc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13605,6 +13605,38 @@  (define-public go-github-com-hugelgupf-socketpair
      "Package socketpair provides bidirectionally connected net.Conns.")
     (license license:bsd-3)))
 
+(define-public go-github-com-cilium-ebpf
+  (package
+    (name "go-github-com-cilium-ebpf")
+    (version "0.11.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cilium/ebpf")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01qwvlbr4fi5j88dfivvivi9avjka3jvw311c2ab75vmg8z9vdps"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/cilium/ebpf"
+       #:tests? #f  ;; Bunch of "operation not permitted", would be a pain to
+                    ;; debug. I'm letting it go
+       #:go ,go-1.20))
+    (propagated-inputs `(("go-github-com-rogpeppe-go-internal" ,go-github-com-rogpeppe-go-internal)
+                         ("go-github-com-kr-text" ,go-github-com-kr-text)
+                         ("go-github-com-kr-pretty" ,go-github-com-kr-pretty)
+                         ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-golang-org-x-exp" ,go-golang-org-x-exp)
+                         ("go-github-com-google-go-cmp-cmp" ,go-github-com-google-go-cmp-cmp)
+                         ("go-github-com-frankban-quicktest" ,go-github-com-frankban-quicktest)))
+    (home-page "https://github.com/cilium/ebpf")
+    (synopsis "eBPF")
+    (description
+     "Package ebpf is a toolkit for working with @code{eBPF} programs.")
+    (license license:expat)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")