diff mbox series

[bug#65966,24/33] gnu: Add go-github-com-jsimonetti-rtnetlink.

Message ID cd5ddacf16be55ae3a8e1507c7b0f0e583ec8218.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-jsimonetti-rtnetlink): New variable.
---
 gnu/packages/golang.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:47 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65966@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3bf113fd70..bb19e9605f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13668,6 +13668,41 @@  (define-public go-github-com-mdlayher-netlink
      "Package netlink provides low-level access to Linux netlink sockets (AF_NETLINK).")
     (license license:expat)))
 
+(define-public go-github-com-jsimonetti-rtnetlink
+  (package
+    (name "go-github-com-jsimonetti-rtnetlink")
+    (version "1.3.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jsimonetti/rtnetlink")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "19kifm0c4lpq1y25g2acnfm5cfrizbygqa50a3sdp9368s1gaay5"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/jsimonetti/rtnetlink"
+       #:go ,go-1.20))
+    (propagated-inputs `(("go-golang-org-x-sync" ,go-golang-org-x-sync)
+                         ("go-golang-org-x-net" ,go-golang-org-x-net)
+                         ("go-golang-org-x-exp" ,go-golang-org-x-exp)
+                         ("go-github-com-mdlayher-socket" ,go-github-com-mdlayher-socket)
+                         ("go-github-com-josharian-native" ,go-github-com-josharian-native)
+                         ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-github-com-mdlayher-netlink" ,go-github-com-mdlayher-netlink)
+                         ("go-github-com-google-go-cmp-cmp" ,go-github-com-google-go-cmp-cmp)
+                         ("go-github-com-cilium-ebpf" ,go-github-com-cilium-ebpf)))
+    (home-page "https://github.com/jsimonetti/rtnetlink")
+    (synopsis "rtnetlink")
+    (description
+     "Package rtnetlink allows the kernel's routing tables to be read and altered.
+Network routes, IP addresses, Link parameters, Neighbor setups, Queueing
+disciplines, Traffic classes and Packet classifiers may all be controlled.  It
+is based on netlink messages.")
+    (license license:expat)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")