diff mbox series

[bug#65967,32/33] gnu: Add go-cloud-google-com-go-workflows.

Message ID c4a2d0243462990be30cdffe2e63a19e6ee17ec9.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-cloud-google-com-go-workflows): New variable.
---
 gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:47 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65967@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fefc127e9d..f6d924d571 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4800,6 +4800,38 @@  (define-public go-github-com-emicklei-go-restful
 with the HTTP protocol definition.")
     (license license:expat)))
 
+(define-public go-cloud-google-com-go-workflows
+  (package
+    (name "go-cloud-google-com-go-workflows")
+    (version "1.12.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/googleapis/google-cloud-go")
+             (commit (string-append "workflows/v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0nz7lrvfc503jgdiywy2h09b96ixcldv0lgxhxabpf3kkgd0qdvj"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "cloud.google.com/go/workflows"
+      #:unpack-path "cloud.google.com/go"
+      #:install-source? #t
+      ;; Source-only package
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Source-only package
+          (delete 'build))))
+    (home-page
+     "https://pkg.go.dev/cloud.google.com/go/workflows")
+    (synopsis #f)
+    (description #f)
+    (license license:asl2.0)))
+
 (define-public go-cloud-google-com-go-compute-metadata
   (package
     (name "go-cloud-google-com-go-compute-metadata")