diff mbox series

[bug#65965,28/33] gnu: Add go-github-com-inconshreveable-mousetrap.

Message ID f3d2145eca701f73ca4af9bbd589d64ae375a76b.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-inconshreveable-mousetrap): New variable.
---
 gnu/packages/golang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:47 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65965@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1c5a72a0ac..873afbf7dd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13768,6 +13768,27 @@  (define-public go-github-com-shurcool-go-importgraphutil
     (description "Common Go code.")
     (license license:expat)))
 
+(define-public go-github-com-inconshreveable-mousetrap
+  (package
+    (name "go-github-com-inconshreveable-mousetrap")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/inconshreveable/mousetrap")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "14gjpvwgx3hmbd92jlwafgibiak2jqp25rq4q50cq89w8wgmhsax"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/inconshreveable/mousetrap"))
+    (home-page "https://github.com/inconshreveable/mousetrap")
+    (synopsis "mousetrap")
+    (description "mousetrap is a tiny library that answers a single question.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")