diff mbox series

[bug#65963,33/33] gnu: Add go-github-com-hugelgupf-p9-cmd-p9ufs.

Message ID 256b4b074c53b804f4bdc88e0f1f9b74882a9b07.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-hugelgupf-p9-cmd-p9ufs): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:47 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65963@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f6d924d571..34ed97da26 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13985,6 +13985,33 @@  (define-public go-github-com-vishvananda-netns
 privileges, so in most cases this code needs to be run as root.")
     (license license:asl2.0)))
 
+(define-public go-github-com-hugelgupf-p9-cmd-p9ufs
+  (package
+    (name "go-github-com-hugelgupf-p9-cmd-p9ufs")
+    (version "0.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hugelgupf/p9")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ylbqh4in95xbj1pmdnxk3rhz0956gqg1m8sbivl30lyr6cmzphb"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/hugelgupf/p9/cmd/p9ufs"
+       #:unpack-path "github.com/hugelgupf/p9"
+       #:go ,go-1.20))
+    (propagated-inputs `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-github-com-u-root-uio-ulog" ,go-github-com-u-root-uio-ulog)))
+    (home-page "https://github.com/hugelgupf/p9")
+    (synopsis "p9")
+    (description
+     "p9 is a Golang 9P2000.L client and server originally written for @code{gVisor}.
+p9 supports Windows, BSD, and Linux on most Go-available architectures.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-gorilla-websocket
   (package
     (name "go-github-com-gorilla-websocket")