diff mbox series

[bug#65947,13/33] gnu: Add go-github-com-u-root-uio-cp.

Message ID 0c37c0f51dbaf30846f48abd4871142d297839b9.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-u-root-uio-cp): New variable.
---
 gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:41 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65947@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cb882058cf..2ce2c57347 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13411,6 +13411,36 @@  (define-public go-github-com-u-root-uio-ulog
     (description #f)
     (license license:bsd-3)))
 
+(define-public go-github-com-u-root-uio-cp
+  (package
+    (name "go-github-com-u-root-uio-cp")
+    (version "0.0.0-20230305220412-3e8cd9d6bf63")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/u-root/uio")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gvv66ixkgwikjx8sjdknvrmd08wv2ia02q8n8y3mnkhrgyyx1yf"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/u-root/uio/cp"
+      #:unpack-path "github.com/u-root/uio"
+      #:install-source? #t
+      ;; Source-only package
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Source-only package
+          (delete 'build))))
+    (home-page "https://github.com/u-root/uio")
+    (synopsis "uio")
+    (description #f)
+    (license license:bsd-3)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")