diff mbox series

[bug#65964,26/33] gnu: Add go-github-com-neelance-sourcemap.

Message ID 9ff139bdbcc2dfa4420a5531b6a14fe43e19eedc.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-neelance-sourcemap): New variable.
---
 gnu/packages/golang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:47 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65964@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7299b1b17a..982c64b660 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13724,6 +13724,27 @@  (define-public go-github-com-neelance-astrewrite
     (description #f)
     (license license:bsd-2)))
 
+(define-public go-github-com-neelance-sourcemap
+  (package
+    (name "go-github-com-neelance-sourcemap")
+    (version "0.0.0-20200213170602-2833bce08e4c")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/neelance/sourcemap")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "05ymjg1z9phf0wp4w058kvf13bmn4skv67chb3r04z69in8y8jih"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/neelance/sourcemap"))
+    (home-page "https://github.com/neelance/sourcemap")
+    (synopsis #f)
+    (description #f)
+    (license license:bsd-2)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")