diff mbox series

[bug#65955,15/33] gnu: Add go-github-com-mdlayher-socket.

Message ID 2fe00441c2b632605ccc9d709120148b4cf86268.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-mdlayher-socket): New variable.
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:46 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65955@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 08fd4c5010..9723c36dc0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13474,6 +13474,35 @@  (define-public go-github-com-u-root-gobusybox-src-pkg-bb
     (description #f)
     (license license:bsd-3)))
 
+(define-public go-github-com-mdlayher-socket
+  (package
+    (name "go-github-com-mdlayher-socket")
+    (version "0.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mdlayher/socket")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1g0bifm7xyfisgk0jmvyshmrnawkwvamn40hvg8f46xs3s5incfz"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/mdlayher/socket"
+       #:go ,go-1.20))
+    (propagated-inputs `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-golang-org-x-sync" ,go-golang-org-x-sync)
+                         ("go-golang-org-x-net" ,go-golang-org-x-net)
+                         ("go-github-com-google-go-cmp-cmp" ,go-github-com-google-go-cmp-cmp)))
+    (home-page "https://github.com/mdlayher/socket")
+    (synopsis "socket")
+    (description
+     "Package socket provides a low-level network connection type which integrates
+with Go's runtime network poller to provide asynchronous I/O and deadline
+support.")
+    (license license:expat)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")