diff mbox series

[bug#65758,v7,40/57] gnu: Add python-django-treebeard.

Message ID f6fd98c3e763873212f2de132cde708c550cf5d0.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:16 a.m. UTC
* gnu/packages/django.scm (python-django-treebeard): New variable.
---
 gnu/packages/django.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index b7f7391df1..7aaca66b7d 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -421,6 +421,34 @@  (define-public python-django-taggit
 application for simple tagging.")
     (license license:bsd-3)))
 
+(define-public python-django-treebeard
+  (package
+    (name "python-django-treebeard")
+    (version "4.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "django-treebeard" version))
+       (sha256
+        (base32 "12s6xyiyjvxnjdbnbj9wab5mdj69d1aj77lkfzmj9mbp0823baw4"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-django
+                             python-sqlparse))
+    (native-inputs (list python-wheel
+                         python-pytest-django))
+    (home-page "https://github.com/django-treebeard/django-treebeard/")
+    (synopsis "Efficient tree implementations for Django")
+    (description
+     "This package provides @code{django-treebeard}, an efficient tree
+implementations for Django.  It includes 3 different tree implementations
+with the same API:
+@itemize
+@item Adjacency List
+@item Materialized Path
+@item Nested Sets
+@end itemize")
+    (license license:bsd-3)))
+
 (define-public python-easy-thumbnails
   (package
     (name "python-easy-thumbnails")