diff mbox series

[bug#65758,v7,06/57] gnu: python-django-extensions: Update to 3.2.0.

Message ID a585e8536826c813ae18a0284cac9b35edede920.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:15 a.m. UTC
* gnu/packages/django.scm (python-django-extensions): Update to 3.2.0.
[source]: Add snippet to disable pip-dependent tests. Update to 3.2.0.
[build-system]: Use pyproject-build-system.
[arguments]: Enable tests.
[native-inputs]: Add python-pygments and tzdata-for-tests.
---
 gnu/packages/django.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 72127bbd34..f56d0f6565 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -204,7 +204,7 @@  (define-public python-django python-django-3.2)
 (define-public python-django-extensions
   (package
     (name "python-django-extensions")
-    (version "3.0.6")
+    (version "3.2.0")
     (source
      (origin
        (method git-fetch)
@@ -214,11 +214,11 @@  (define-public python-django-extensions
              (commit version)))
        (file-name (string-append name "-" version))
        (sha256
-        (base32
-         "0sra6hazqvspxd1pnx5cj7gia1rkaz3hn06ib4wd0frc167f5afy"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:tests? #f)) ;XXX: requires a Postgres or MySQL database
+        (base32 "1wfzlfjbicvk093xqx3qw633ap2khk6kc1ph2kwfk72wxy8yq9lf"))
+       (snippet ; Disable pip-dependent tests.
+        '(delete-file "tests/management/commands/test_pipchecker.py"))))
+    (build-system pyproject-build-system)
+    ;; TODO More tests can be enabled with a Postgres or MySQL database
     (propagated-inputs
      (list python-six python-vobject python-werkzeug python-dateutil
            python-django))
@@ -226,10 +226,12 @@  (define-public python-django-extensions
      (list python-mock
            python-factory-boy
            python-tox
+           python-pygments
            python-pytest
            python-pytest-cov
            python-pytest-django
-           python-shortuuid))
+           python-shortuuid
+           tzdata-for-tests))
     (home-page
      "https://github.com/django-extensions/django-extensions")
     (synopsis "Custom management extensions for Django")