diff mbox series

[bug#65758,v7,52/57] gnu: Add python-wagtail.

Message ID a4d064d2effd6ea97589c489165ca7b338fe922a.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:16 a.m. UTC
* gnu/packages/django.scm (python-wagtail): New variable.
---
 gnu/packages/django.scm | 70 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 70 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 7a8dd0a9b5..8fea2a1723 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1699,3 +1699,73 @@  (define-public python-telepath
      "This package provides @code{telepath}, a library for exchanging data
 between Python and JavaScript.")
     (license license:bsd-3)))
+
+(define-public python-wagtail
+  (package
+    (name "python-wagtail")
+    (version "5.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "wagtail" version))
+       (sha256
+        (base32 "1fyjxb4g0mnmpr802jddylj6lc2fy4pf3zazsr2k9nx5hzgj3gfy"))))
+    (build-system pyproject-build-system)
+    (arguments
+     `(#:test-flags '("--pythonpath=."
+                      "--settings=wagtail.test.settings"
+                      ;; disabling failing azure tests
+                      "-k" "not test_azure_cdn_get_client"
+                      "-k" "not test_azure_cdn_purge"
+                      "-k" "not test_azure_front_door_get_client"
+                      "-k" "not test_azure_front_door_purge")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'hiding-failing-tests-imports
+           (lambda _
+             (substitute* "wagtail/contrib/frontend_cache/tests.py"
+               (("from azure" all)
+                (string-append "#" all)))))
+         (replace 'check
+           (lambda* (#:key tests? test-flags #:allow-other-keys)
+             (if tests?
+                 (apply invoke "django-admin" "test" test-flags)))))))
+    (propagated-inputs
+     (list python-anyascii
+           python-beautifulsoup4
+           python-django-4.0
+           python-django-filter
+           python-django-modelcluster
+           python-django-taggit
+           python-django-permissionedforms
+           python-django-treebeard
+           python-django-rest-framework
+           python-draftjs-exporter
+           python-html5lib
+           python-l18n
+           python-openpyxl
+           python-pillow
+           python-requests
+           python-telepath
+           python-willow))
+    (native-inputs
+     ;; python-azure-mgmt-cdn ;failing tests
+     ;; python-azure-mgmt-frontdoor ;failing tests
+     (list python-boto3
+           python-dateutil
+           python-doc8
+           python-docutils
+           python-elasticsearch
+           python-freezegun
+           python-isort
+           python-jinja2
+           python-jinjalint
+           python-polib
+           python-pytz
+           python-unidecode
+           python-wagtail-factories))
+    (home-page "https://wagtail.org/")
+    (synopsis "A Content Management System (CMS)")
+    (description "This package provides a Content Management System based on
+Django.")
+    (license license:bsd-3)))