diff mbox series

[bug#65758,v7,44/57] gnu: Add python-django-request.

Message ID 812cce0bdef26febf9ec83f6a84e80888c5a46c6.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:16 a.m. UTC
* gnu/packages/django.scm (python-django-request): New variable.
---
 gnu/packages/django.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 7aaca66b7d..9c5460f788 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -310,6 +310,43 @@  (define-public python-django-localflavor
 that are useful for particular countries or cultures.")
     (license license:bsd-3)))
 
+(define-public python-django-request
+  (package
+    (name "python-django-request")
+    (version "1.6.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/django-request/django-request")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1hncmcxral2h51jrgvzlhwqk37xyq7wjbf79hh4ik13prigxabwi"))))
+    (build-system pyproject-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (invoke "python" "runtests.py")
+                 (format #t "test suite not run~%")))))))
+    (propagated-inputs
+     (list python-dateutil python-django python-six))
+    (native-inputs
+     (list python-sqlparse python-mock
+           tzdata-for-tests))
+    (home-page "https://django-request.readthedocs.io")
+    (synopsis
+     "Statistics module for django")
+    (description
+     "This package provides a statistics module for django.  It stores
+requests in a database for admins to see, it can also be used to get
+statistics on who is online etc.")
+    (license license:expat)))
+
 (define-public python-django-requests-debug-toolbar
   (package
     (name "python-django-requests-debug-toolbar")