diff mbox series

[bug#65758,v7,47/57] gnu: Add python-l18n.

Message ID 46c59f3f372e96e2c93450175d750d8de6e8dc37.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:16 a.m. UTC
* gnu/packages/python-xyz.scm (python-l18n): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 71a0c581c9..b5574100de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1891,6 +1891,26 @@  (define-public python-shortuuid
 module and then similar looking characters are removed.")
     (license license:bsd-3)))
 
+(define-public python-l18n
+  (package
+    (name "python-l18n")
+    (version "2021.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "l18n" version))
+       (sha256
+        (base32 "0j6q89d1mk03snvj4v1600fbrxjlq59k5490rhsp3lbkss8fhmhr"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-wheel))
+    (propagated-inputs (list python-pytz python-six))
+    (home-page "https://github.com/tkhyn/l18n")
+    (synopsis "Internationalization for timezones and territories")
+    (description
+     "This package provides internationalization for @code{python-pytz}
+timezones and territories.")
+    (license license:expat)))
+
 (define-public python-logwrap
   (package
     (name "python-logwrap")