diff mbox series

[bug#65758,v7,04/57] gnu: python-distributed: Disable failing tests.

Message ID b74afed0db32847421c1c1f1b4706cb353e2ddb7.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:15 a.m. UTC
* gnu/packages/python-science.scm (python-distributed): Disable failing tests.
---
 gnu/packages/python-science.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 4a010b4127..ab2ceb0b2c 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1296,7 +1296,8 @@  (define-public python-distributed
                 "test_tls_temporary_credentials_functional"
                 "test_variable_in_task"
                 "test_worker_preload_text"
-                "test_worker_uses_same_host_as_nanny")
+                "test_worker_uses_same_host_as_nanny"
+                "test_nanny_timeout") ; access to 127.0.0.1
                " and not ")
 
               ;; These fail because it doesn't find dask[distributed]
@@ -1319,7 +1320,8 @@  (define-public python-distributed
 
               ;; These tests are rather flaky
               " and not test_quiet_quit_when_cluster_leaves"
-              " and not multiple_clients_restart"))
+              " and not multiple_clients_restart"
+              " and not test_steal_twice"))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'versioneer