diff mbox series

[bug#65758,v7,27/57] gnu: python-rjsmin: Update to 1.2.1.

Message ID 1ec21bb4162a529d719a7eec02ed2d21fbd0c4b0.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:15 a.m. UTC
* gnu/packages/python-xyz.scm (python-rjsmin): Update to 1.2.1.
[source](snippet): Remove trailing #t.
[build-system]: Use pyproject-build-sytem.
[description]: Fix spacing.
[arguments]: Delete #:phases and #:tests?.
---
 gnu/packages/python-xyz.scm | 26 +++++++-------------------
 1 file changed, 7 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 847e3bcc3b..c1237725b3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20935,38 +20935,26 @@  (define-public python-rcssmin
 (define-public python-rjsmin
   (package
     (name "python-rjsmin")
-    (version "1.1.0")
+    (version "1.2.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "rjsmin" version))
         (sha256
-         (base32
-          "0cmc72rlkvzz8fl89bc83czkx0pcvhzj7yn7m29r8pgnf5fcfpdi"))
+         (base32 "04almyw2b5r9xq9961qgzhskjjhk82djf1s3m5vqfhqiw3l2p60z"))
         (modules '((guix build utils)))
         (snippet
          '(begin
-            (for-each delete-file (find-files "bench" "\\.js$"))
-            #t))))
-    (build-system python-build-system)
-    (arguments
-     '(#:tests? #f  ; Not all test files included.
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (if tests?
-               (invoke "py.test" "-vv" "tests")
-               #t))))))
+            (for-each delete-file (find-files "bench" "\\.js$"))))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-pytest))
     (home-page "http://opensource.perlig.de/rjsmin/")
     (synopsis "Javascript Minifier")
     (description "@code{rJSmin} is a javascript minifier written in Python.  The
-     minifier is based on the semantics of jsmin.c by Douglas Crockford.  The module
-     is a re-implementation aiming for speed, so it can be used at runtime (rather
-                                                                            than during a preprocessing step).")
+minifier is based on the semantics of jsmin.c by Douglas Crockford.  The module
+is a re-implementation aiming for speed, so it can be used at runtime (rather
+than during a preprocessing step).")
     (license license:asl2.0)))
 
 (define-public python-xopen