diff mbox series

[bug#65758,v7,43/57] gnu: Add python-willow.

Message ID e15e4e15920fca45dcb07eb2a0e4162a5d552caa.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:16 a.m. UTC
* gnu/packages/python-xyz.scm (python-willow): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b40f711d72..e23d21d2bc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8833,6 +8833,32 @@  (define-public python-pixelmatch
 metrics.")
     (license license:isc)))
 
+(define-public python-willow
+  (package
+    (name "python-willow")
+    (version "1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Willow" version))
+       (sha256
+        (base32 "12k5mv9jh0f5vjm87ss4d7kbkrcb3n5fa0gk9pvf9n3jk3d2rr1z"))))
+    (build-system pyproject-build-system)
+    (inputs
+     (list freetype lcms libjpeg-turbo libtiff libwebp openjpeg zlib))
+    (propagated-inputs
+     (list python-defusedxml python-filetype))
+    (home-page "https://github.com/wagtail/Willow")
+    (synopsis
+     "Combine multiple Python image libraries into one API")
+    (description
+     "Willow is a simple image library that combines the APIs of Pillow, Wand
+and OpenCV.  It converts the image between the libraries when necessary.
+Willow currently has basic resize and crop operations, face and feature
+detection and animated GIF support.  New operations and library integrations
+can also be easily implemented.")
+    (license license:bsd-3)))
+
 (define-public python-imagecodecs
   (package
     (name "python-imagecodecs")