diff mbox series

[bug#65758,v7,09/57] gnu: python-django-simple-math-captcha: Update to 1.0.9-0-61adb4f.

Message ID bc095a4abb6ff7ce341e2744cb767ce52c4f2606.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:15 a.m. UTC
* gnu/packages/django.scm (python-django-simple-math-captcha): Update to 1.0.9-0-61adb4f.
[build-system]: Use pyproject-build-system.
[arguments](phases): Delete phase patch-six-imports.
[propagated-inputs]: Delete python-six.
---
 gnu/packages/django.scm | 66 +++++++++++++++++++----------------------
 1 file changed, 30 insertions(+), 36 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 84f18fc3d1..e2754b2d57 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -324,44 +324,38 @@  (define-public python-django-localflavor
     (license license:bsd-3)))
 
 (define-public python-django-simple-math-captcha
-  (package
-    (name "python-django-simple-math-captcha")
-    (version "1.0.9")
-    (home-page "https://github.com/alsoicode/django-simple-math-captcha")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url home-page)
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0fhy9k8haqa1296v0qpg1b5w7y3pyw9qi9z9laj5ijry1gk35qaw"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'patch-six-imports
-                    (lambda _
-                      ;; Django no longer bundles six, adjust the imports
-                      ;; accordingly.  The six dependency can likely be
-                      ;; removed in the next version.
-                      (substitute* (find-files "." "\\.py$")
-                        (("from django\\.utils import six")
-                         "import six"))
-                      #t))
-                  (replace 'check
-                    (lambda _
-                      (invoke "python" "runtests.py"))))))
-    (native-inputs
-     (list python-mock))
-    (propagated-inputs
-     (list python-django python-six))
-    (synopsis "Easy-to-use math field/widget captcha for Django forms")
-    (description
-     "A multi-value-field that presents a human answerable question,
+  (let ((commit "61adb4f43bfc654da61fa7b84ea4f455e31f0bd2")
+        (revision "0"))
+    (package
+      (name "python-django-simple-math-captcha")
+      (version (git-version "1.0.9" revision commit))
+      (home-page "https://github.com/alsoicode/django-simple-math-captcha")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "02fim6xk4islil02xg7j5nqfpmgwzyqni1y17a082fz35d94jd3i"))))
+      (build-system pyproject-build-system)
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (replace 'check
+             (lambda _
+               (invoke "python" "runtests.py"))))))
+      (native-inputs
+       (list python-mock))
+      (propagated-inputs
+       (list python-django))
+      (synopsis "Easy-to-use math field/widget captcha for Django forms")
+      (description
+       "A multi-value-field that presents a human answerable question,
 with no settings.py configuration necessary, but instead can be configured
 with arguments to the field constructor.")
-    (license license:asl2.0)))
+      (license license:asl2.0))))
 
 (define-public python-django-classy-tags
   (package