diff mbox series

[bug#65758,v7,17/57] gnu: graphite-web: Update to 1.1.10-0-dca59dc.

Message ID 4226460e0f01130fa5e5530e432f5b9c36e65318.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:15 a.m. UTC
* gnu/packages/monitoring.scm (graphite-web): Update to 1.1.10-0-dca59dc.
[build-system]: Use pyproject-build-system.
[arguments](tests?): Enable tests.
(phases): Remove trailing #t.
[propagated-inputs]: Move from python-django-2.2 to python-django-3.2.
---
 gnu/packages/monitoring.scm | 80 +++++++++++++++++++------------------
 1 file changed, 41 insertions(+), 39 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 3238f11fb4..1d77dbd75f 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -452,47 +452,49 @@  (define-public python-carbon
     (license license:asl2.0)))
 
 (define-public graphite-web
-  (package
-    (name "graphite-web")
-    (version "1.1.7")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "graphite-web" version))
-       (sha256
-        (base32
-         "1l5a5rry9cakqxamvlx4xq63jifmncb6815bg9vy7fg1zyd3pjxk"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f               ;XXX: not in PyPI release & requires database
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'relax-requirements
-           (lambda _
-             (substitute* "setup.py"
-               ;; Allow newer versions of django-tagging.
-               (("django-tagging==")
-                "django-tagging>="))
-             #t))
-         ;; Don't install to /opt
-         (add-after 'unpack 'do-not-install-to-/opt
-           (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
-    (propagated-inputs
-     (list python-cairocffi
-           python-pytz
-           python-whisper
-           python-django-2.2
-           python-django-tagging
-           python-scandir
-           python-urllib3
-           python-pyparsing
-           python-txamqp))
-    (home-page "https://graphiteapp.org/")
-    (synopsis "Scalable realtime graphing system")
-    (description "Graphite is a scalable real-time graphing system that does
+  (let ((commit "dca59dc72ae28ffdae659232c10c60aa598536eb")
+        (revision "0"))
+    (package
+      (name "graphite-web")
+      (version "1.1.10")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/graphite-project/graphite-web")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "06yzvg2r9lx92swp51k27qhxf178nq6y9px5kcmpv31ikc3nri7q"))))
+      (build-system pyproject-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'relax-requirements
+             (lambda _
+               (substitute* "setup.py"
+                 ;; Allow newer versions of django-tagging.
+                 (("django-tagging==")
+                  "django-tagging>="))))
+           ;; Don't install to /opt
+           (add-after 'unpack 'do-not-install-to-/opt
+             (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1"))))))
+      (propagated-inputs
+       (list python-cairocffi
+             python-pytz
+             python-whisper
+             python-django-3.2
+             python-django-tagging
+             python-scandir
+             python-urllib3
+             python-pyparsing
+             python-txamqp))
+      (home-page "https://graphiteapp.org/")
+      (synopsis "Scalable realtime graphing system")
+      (description "Graphite is a scalable real-time graphing system that does
 two things: store numeric time-series data, and render graphs of this data on
 demand.")
-    (license license:asl2.0)))
+      (license license:asl2.0))))
 
 (define-public python-prometheus-client
   (package