diff mbox series

[bug#65758,v7,14/57] gnu: python-django-picklefield: Update to 3.1.0.

Message ID 3e59d6f9f51f60036fa2260b37cf26b1f000f783.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:15 a.m. UTC
* gnu/packages/django.scm (python-django-picklefield): Update to 3.1.0.
[build-system] Use pyproject-build-system.
[arguments](phases): Delete -v2 django@2.2 flag.
[propagated-inputs] Replace python-django@2.2 by python-django.
---
 gnu/packages/django.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 3042dc59db..88ed2e9d35 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -762,7 +762,7 @@  (define-public python-dj-database-url
 (define-public python-django-picklefield
   (package
     (name "python-django-picklefield")
-    (version "3.0.1")
+    (version "3.1.0")
     (home-page "https://github.com/gintas/django-picklefield")
     ;; Use a git checkout because the PyPI release lacks tests.
     (source
@@ -773,19 +773,16 @@  (define-public python-django-picklefield
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32
-          "0ni7bc86k0ra4pc8zv451pzlpkhs1nyil1sq9jdb4m2mib87b5fk"))))
-    (build-system python-build-system)
+         (base32 "00d8sm6cnkv5bxbs2a3qrm4g69nlaa1wari7mc697df8q91v6r0n"))))
+    (build-system pyproject-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
                   (replace 'check
                     (lambda _
-                      (invoke "python" "-m" "django" "test" "-v2"
+                      (invoke "python" "-m" "django" "test"
                               "--settings=tests.settings"))))))
     (propagated-inputs
-     ;; XXX: Picklefield has not been updated in 10+ years and fails tests
-     ;; with Django 3.2.
-     `(("python-django@2.2" ,python-django-2.2)))
+     (list python-django))
     (synopsis "Pickled object field for Django")
     (description "Pickled object field for Django")
     (license license:expat)))