diff mbox series

[bug#65758,v7,57/57] gnu: python-django-debug-toolbar: Update to 3.8.1.

Message ID 0825cb0afe3bbc8969e2a3094aaff85c839307ba.1693991781.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65758,v7,01/57] gnu: python-django-4.0: Update to 4.0.9. | expand

Commit Message

Nicolas Graves Sept. 6, 2023, 9:16 a.m. UTC
* gnu/packages/django.scm (python-django-debug-toolbar): Update to 3.8.1.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-hatchling.
[arguments](phases): Ensure tests are only run when requested.
---
 gnu/packages/django.scm | 18 +++++++++++-------
 1 file changed, 11 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index fc9977914b..330915124b 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -719,7 +719,7 @@  (define-public python-django-allauth
 (define-public python-django-debug-toolbar
   (package
     (name "python-django-debug-toolbar")
-    (version "3.2.1")
+    (version "3.8.1")
     (source
      (origin
        (method git-fetch)
@@ -728,19 +728,23 @@  (define-public python-django-debug-toolbar
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1m1j2sx7q0blma0miswj3c8hrfi5q4y5cq2b816v8gagy89xgc57"))))
-    (build-system python-build-system)
+        (base32 "1h8m5my90h3p93lqi9dm60ih0lac7awn1svdqaqci6qykkdk0l8s"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
      (list python-sqlparse python-django))
     (native-inputs
-     (list python-django-jinja python-html5lib tzdata-for-tests))
+     (list python-django-jinja
+           python-html5lib
+           tzdata-for-tests
+           python-hatchling))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "make" "test"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (if tests?
+                 (invoke "make" "test")
+                 (format #t "test suite not run~%")))))))
     (home-page
      "https://github.com/jazzband/django-debug-toolbar")
     (synopsis "Toolbar to help with developing Django applications")