diff mbox series

[bug#70395,kde-team,20/63] gnu: Add kcompletion-6.

Message ID f3464f8df1caa5a128aa65e23f69501dfa93f45c.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:46 p.m. UTC
* gnu/packages/kde-frameworks.scm (kcompletion-6): New variable.
(kcompletion): Inherit above.

Change-Id: Id1ba6af3cd5929ce40a45c85252e56005370b1cf
---
 gnu/packages/kde-frameworks.scm | 31 ++++++++++++++++++++++++++-----
 1 file changed, 26 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 443307ecc1..d1a57db53d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2053,10 +2053,10 @@  (define-public kauth
 utilities.")
     (license license:lgpl2.1+)))
 
-(define-public kcompletion
+(define-public kcompletion-6
   (package
     (name "kcompletion")
-    (version "5.114.0")
+    (version "6.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -2065,12 +2065,13 @@  (define-public kcompletion
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0qvdxqlh1dklkbmqfjg5gc3dkdicgzn6q5lgvyf8cv46dinj6mwc"))))
+                "1j29hh8w8zv9h0rkm76zhr2f691ns937ix5hifhbx26x3szbxq71"))))
     (build-system qt-build-system)
     (native-inputs
-     (list extra-cmake-modules qttools-5))
+     (list extra-cmake-modules qttools))
     (inputs
-     (list kconfig kwidgetsaddons qtbase-5))
+     (list kcodecs-6 kconfig-6 kwidgetsaddons-6))
+    (arguments (list #:qtbase qtbase))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Powerful autocompletion framework and widgets")
     (description "This framework helps implement autocompletion in Qt-based
@@ -2078,6 +2079,26 @@  (define-public kcompletion
 integrated it into your application's other widgets.")
     (license license:lgpl2.1+)))
 
+(define-public kcompletion
+  (package
+    (inherit kcompletion-6)
+    (name "kcompletion")
+    (version "5.114.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0qvdxqlh1dklkbmqfjg5gc3dkdicgzn6q5lgvyf8cv46dinj6mwc"))))
+    (native-inputs
+     (list extra-cmake-modules qttools-5))
+    (inputs
+     (list kconfig kwidgetsaddons))
+    (arguments '())))
+
 (define-public kcontacts
   (package
     (name "kcontacts")