diff mbox series

[bug#70395,kde-team,62/63] gnu: Add kdesu-6.

Message ID 8fb90193ee45aa7a76341298f5f20d87c52b6449.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:47 p.m. UTC
* gnu/packages/kde-frameworks.scm (kdesu-6): New variable.
(kdesu): Inherit above.

Change-Id: I74f948875022b71bcdc54aa31ca4613e24ebfdff
---
 gnu/packages/kde-frameworks.scm | 38 +++++++++++++++++++++++++++------
 1 file changed, 32 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 875f9df88e..84222a495d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3606,10 +3606,10 @@  (define-public kdesignerplugin
 ini-style description files.")
     (license license:lgpl2.1+)))
 
-(define-public kdesu
+(define-public kdesu-6
   (package
     (name "kdesu")
-    (version "5.114.0")
+    (version "6.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -3618,14 +3618,17 @@  (define-public kdesu
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "14dcf32izn4lxr8vx372rfznflc1rcxwanx06phkd8mx9zyg4jxr"))))
-    (build-system cmake-build-system)
+                "0zl2p9319r8q85p3j64w7p7nmjh53z6fha8kkgf3fdfdikh9g8x6"))))
+    (build-system qt-build-system)
     (propagated-inputs
-     (list kpty))
+     (list kpty-6))
     (native-inputs
      (list extra-cmake-modules))
     (inputs
-     (list kconfig kcoreaddons ki18n kservice qtbase-5))
+     (list kconfig-6 kcoreaddons-6 ki18n-6 kservice-6))
+    (arguments (list
+                #:tests? #f ;; FIXME: kdesutest test fail.
+                #:qtbase qtbase))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "User interface for running shell commands with root privileges")
     (description "KDESU provides functionality for building GUI front ends for
@@ -3633,6 +3636,29 @@  (define-public kdesu
 with su and ssh respectively.")
     (license license:lgpl2.1+)))
 
+(define-public kdesu
+  (package
+    (inherit kdesu-6)
+    (name "kdesu")
+    (version "5.114.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "14dcf32izn4lxr8vx372rfznflc1rcxwanx06phkd8mx9zyg4jxr"))))
+    (build-system cmake-build-system)
+    (propagated-inputs
+     (list kpty))
+    (native-inputs
+     (list extra-cmake-modules))
+    (inputs
+     (list kconfig kcoreaddons ki18n kservice qtbase-5))
+    (arguments '())))
+
 (define-public kemoticons
   (package
     (name "kemoticons")