diff mbox series

[bug#70395,kde-team,50/63] gnu: Add kwallet-6.

Message ID 7fd4502ee86db2e69b1f2966eaf8773e42f348e3.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:47 p.m. UTC
* gnu/packages/kde-frameworks.scm (kwallet-6): New variable.
(kwallet): Inherit above.

Change-Id: I12216ad70cc09b35ab0240f8e83808948c9a2985
---
 gnu/packages/kde-frameworks.scm | 69 +++++++++++++++++++++++++--------
 1 file changed, 53 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 7927bf3e47..b77c12a613 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -4278,10 +4278,10 @@  (define-public ktextwidgets
     ;; dual licensed
     (license (list license:lgpl2.0+ license:lgpl2.1+))))
 
-(define-public kwallet
+(define-public kwallet-6
   (package
     (name "kwallet")
-    (version "5.114.0")
+    (version "6.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -4290,16 +4290,59 @@  (define-public kwallet
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1cji8bvy5m77zljyrrgipsw8pxcds1sgikxlq3sdfxymcsw2wr36"))))
+                "04s6p1sl24dd85c4n2rxj3z5kf3gc8lx5a4k1x73lr77vyxsv4ng"))))
     (build-system cmake-build-system)
     (arguments
      (list #:phases
-       #~(modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests? ;; Seems to require network.
-               (invoke "ctest" "-E"
-                       "(fdo_secrets_test)")))))))
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests? ;; Seems to require network.
+                     (invoke "ctest" "-E"
+                             "(fdo_secrets_test)")))))))
+    (native-inputs
+     (list extra-cmake-modules kdoctools-6))
+    (inputs
+     (list gpgme
+           kauth-6
+           kcodecs-6
+           kconfig-6
+           kconfigwidgets-6
+           kcoreaddons-6
+           kdbusaddons-6
+           kdoctools-6
+           kiconthemes-6
+           ki18n-6
+           knotifications-6
+           kservice-6
+           kwidgetsaddons-6
+           kwindowsystem-6
+           libgcrypt
+           phonon
+           qgpgme
+           qca-qt6
+           qtbase))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Safe desktop-wide storage for passwords")
+    (description "This framework contains an interface to KWallet, a safe
+desktop-wide storage for passwords and the kwalletd daemon used to safely store
+the passwords on KDE work spaces.")
+    (license license:lgpl2.1+)))
+
+(define-public kwallet
+  (package
+    (inherit kwallet-6)
+    (name "kwallet")
+    (version "5.114.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1cji8bvy5m77zljyrrgipsw8pxcds1sgikxlq3sdfxymcsw2wr36"))))
     (native-inputs
      (list extra-cmake-modules kdoctools))
     (inputs
@@ -4321,13 +4364,7 @@  (define-public kwallet
            phonon
            qgpgme
            qca
-           qtbase-5))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "Safe desktop-wide storage for passwords")
-    (description "This framework contains an interface to KWallet, a safe
-desktop-wide storage for passwords and the kwalletd daemon used to safely store
-the passwords on KDE work spaces.")
-    (license license:lgpl2.1+)))
+           qtbase-5))))
 
 (define-public kxmlgui
   (package