diff mbox series

[bug#70395,kde-team,22/63] gnu: Add kwindowsystem-6.

Message ID 8f65906daa107be595159bdafc632edb1b3f0327.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:46 p.m. UTC
* gnu/packages/kde-frameworks.scm (kwindowsystem-6): New variable.
(kwindowsystem): Inherit above.

Change-Id: Ib5c2d5d396ea372ddc0284b24575d33c3a57a4ff
---
 gnu/packages/kde-frameworks.scm | 49 +++++++++++++++++++++++++++------
 1 file changed, 41 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 13253b7a1a..8eb3e138e4 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1611,10 +1611,10 @@  (define-public kwidgetsaddons
                         "(ksqueezedtextlabelautotest|\
 kwidgetsaddons-kcolumnresizertest)")))))))))
 
-(define-public kwindowsystem
+(define-public kwindowsystem-6
   (package
     (name "kwindowsystem")
-    (version "5.114.0")
+    (version "6.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1623,19 +1623,24 @@  (define-public kwindowsystem
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "03xbsf1pmswd2kpn3pdszp4vndclsh7j02fp22npxaxllmfr4va9"))))
+                "15b54bacasg7x3vfky0601vr1n2rjm1v81lga00qp8xahcw581wc"))))
     (build-system cmake-build-system)
     (native-inputs
      (list extra-cmake-modules
            pkg-config
+           wayland; for wayland-scanner
            dbus ; for the tests
-           openbox ; for the tests
-           qttools-5
+           openbox ; for the test
+           qttools
            xorg-server-for-tests)) ; for the tests
     (inputs
-     (list libxrender
-           qtbase-5
-           qtx11extras
+     (list qtbase
+           qtdeclarative
+           qtwayland
+           wayland-protocols
+           plasma-wayland-protocols
+           libxkbcommon
+           wayland
            xcb-util-keysyms
            xcb-util-wm))
     (arguments
@@ -1668,6 +1673,34 @@  (define-public kwindowsystem
     ;; the lgpl2.1. Some source files are under non-copyleft licenses.
     (license license:lgpl2.1+)))
 
+(define-public kwindowsystem
+  (package
+    (inherit kwindowsystem-6)
+    (name "kwindowsystem")
+    (version "5.114.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "03xbsf1pmswd2kpn3pdszp4vndclsh7j02fp22npxaxllmfr4va9"))))
+    (native-inputs
+     (list extra-cmake-modules
+           pkg-config
+           dbus ; for the tests
+           openbox ; for the tests
+           qttools-5
+           xorg-server-for-tests)) ; for the tests
+    (inputs
+     (list libxrender
+           qtbase-5
+           qtx11extras
+           xcb-util-keysyms
+           xcb-util-wm))))
+
 (define-public modemmanager-qt
   (package
     (name "modemmanager-qt")