diff mbox series

[bug#70395,kde-team,02/63] gnu: Add kquickcharts-6.

Message ID 450764c37670a532cd1df30487ec2b3722edfd23.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:46 p.m. UTC
* gnu/packages/kde-frameworks.scm (kquickcharts-6): New variable.
(kquickcharts): Inherit above.
Change-Id: Ic75e26b296930b95dde243df1383311e9276b180

Change-Id: I383890f11771ce39dfea22ed0a7bb2fead0aec38
---
 gnu/packages/kde-frameworks.scm | 34 ++++++++++++++++++++++++---------
 1 file changed, 25 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 7be9f160a2..e015466b2e 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -186,8 +186,32 @@  (define-public extra-cmake-modules
 common build settings used in software produced by the KDE community.")
     (license license:bsd-3)))
 
+(define-public kquickcharts-6
+  (package
+    (name "kquickcharts")
+    (version "6.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/frameworks/"
+                                  (version-major+minor version)
+                                  "/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1ix4wc37mql6cdkh2i5ddwdr0p72i0l7whphd3zb26qszww5f6vn"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules glslang pkg-config))
+    (inputs (list qtbase qtdeclarative qtshadertools))
+    (home-page "https://api.kde.org/frameworks/kquickcharts/html/index.html")
+    (synopsis "QtQuick plugin providing high-performance charts")
+    (description
+     "The Quick Charts module provides a set of charts that can be
+used from QtQuick applications for both simple display of data as well as
+continuous display of high-volume data.")
+    (license (list license:lgpl2.1 license:lgpl3))))
+
 (define-public kquickcharts
   (package
+    (inherit kquickcharts-6)
     (name "kquickcharts")
     (version "5.114.0")
     (source (origin
@@ -209,15 +233,7 @@  (define-public kquickcharts
                               (setenv "QT_QPA_PLATFORM" "offscreen")
                               (invoke "ctest")))))))
     (inputs (list qtbase-5 qtdeclarative-5 qtquickcontrols2-5
-                  xorg-server-for-tests))
-    (native-inputs (list extra-cmake-modules glslang pkg-config))
-    (home-page "https://api.kde.org/frameworks/kquickcharts/html/index.html")
-    (synopsis "QtQuick plugin providing high-performance charts")
-    (description
-     "The Quick Charts module provides a set of charts that can be
-used from QtQuick applications for both simple display of data as well as
-continuous display of high-volume data.")
-    (license (list license:lgpl2.1 license:lgpl3))))
+                  xorg-server-for-tests))))
 
 (define-public phonon
   (package