diff mbox series

[bug#70395,kde-team,03/63] gnu: Add attica-6.

Message ID 6040527e4b98e8a81e6e600e6d6ccf8326e90b03.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Z572 April 15, 2024, 12:46 p.m. UTC
* gnu/packages/kde-frameworks.scm (attica-6): New variable.
(attica): Inherit above.
Change-Id: I9e7fc3dc96b1534c5ec61b0fc483df6918d91d3e

Change-Id: Ie46de95fc47fec4d845f91912daacc5a11c9d7cd
---
 gnu/packages/kde-frameworks.scm | 29 ++++++++++++++++++++++-------
 1 file changed, 22 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index e015466b2e..235c07e5f7 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -310,10 +310,10 @@  (define-public phonon-backend-gstreamer
 ;; Tier 1 frameworks depend only on Qt (and possibly a small number of other
 ;; third-party libraries), so can easily be used by an Qt-based project.
 
-(define-public attica
+(define-public attica-6
   (package
     (name "attica")
-    (version "5.114.0")
+    (version "6.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -322,8 +322,11 @@  (define-public attica
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0gkdsm1vyyyxxyl4rni9s2bdz5w6zphzjl58fddjl899da06hqfq"))))
+                "185mgnnq8lqr3k59b3j73i9kzvcx6q7w70h7g07rsfkmlv4wlgcb"))))
     (build-system cmake-build-system)
+    (native-inputs
+     (list extra-cmake-modules))
+    (inputs (list qtbase))
     (arguments
      (list
       #:phases
@@ -333,10 +336,6 @@  (define-public attica
               ;; These tests require network access.
               (substitute* "autotests/CMakeLists.txt"
                 ((".*providertest.cpp") "")))))))
-    (native-inputs
-     (list extra-cmake-modules))
-    (inputs
-     (list qtbase-5))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Open Collaboration Service client library")
     (description "Attica is a Qt library that implements the Open
@@ -351,6 +350,22 @@  (define-public attica
 http://freedesktop.org/wiki/Specifications/open-collaboration-services/")
     (license (list license:lgpl2.1+ license:lgpl3+))))
 
+(define-public attica
+  (package
+    (inherit attica-6)
+    (name "attica")
+    (version "5.114.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0gkdsm1vyyyxxyl4rni9s2bdz5w6zphzjl58fddjl899da06hqfq"))))
+    (inputs (list qtbase-5))))
+
 (define-public bluez-qt
   (package
     (name "bluez-qt")