diff mbox series

[bug#70395,kde-team,10/63] gnu: Add kidletime-6.

Message ID 8bfcd0f68f14a4cbaac2b4319f37b3c6b896b13f.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:46 p.m. UTC
* gnu/packages/kde-frameworks.scm (kidletime-6): New variable.
(kidletime): Inherit above.

Change-Id: I904d5519d3e72852f4e0a5071afddfd6e343b273
---
 gnu/packages/kde-frameworks.scm | 43 ++++++++++++++++++++++++++-------
 1 file changed, 34 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index fc0c8983a5..170a4c4e44 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1041,8 +1041,41 @@  (define-public ki18n
     (inputs
      (list qtbase-5 qtdeclarative-5 qtscript iso-codes))))
 
+(define-public kidletime-6
+  (package
+    (name "kidletime")
+    (version "6.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/frameworks/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0fmgbx3n7fjcnbym82h6jbq2rsml9426ga9sxh5m5sfjkw95rn68"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     (list extra-cmake-modules pkg-config
+           ;; for wayland-scanner
+           wayland))
+    (inputs
+     (list qtbase
+           qtwayland
+           wayland
+           plasma-wayland-protocols
+           wayland-protocols
+           libxkbcommon))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Reporting of idle time of user and system")
+    (description "KIdleTime is a singleton reporting information on idle time.
+It is useful not only for finding out about the current idle time of the PC,
+but also for getting notified upon idle time events, such as custom timeouts,
+or user activity.")
+    (license (list license:gpl2+ license:lgpl2.1+))))
+
 (define-public kidletime
   (package
+    (inherit kidletime-6)
     (name "kidletime")
     (version "5.114.0")
     (source (origin
@@ -1054,19 +1087,11 @@  (define-public kidletime
               (sha256
                (base32
                 "06sc9w54g4n7s5gjkqz08rgcz6v3pr0bdgx3gbjgzass6l4m8w7p"))))
-    (build-system cmake-build-system)
     (native-inputs
      (list extra-cmake-modules pkg-config))
     (inputs
      (list libxscrnsaver ; X-Screensaver based poller, fallback mode
-           qtbase-5 qtx11extras))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "Reporting of idle time of user and system")
-    (description "KIdleTime is a singleton reporting information on idle time.
-It is useful not only for finding out about the current idle time of the PC,
-but also for getting notified upon idle time events, such as custom timeouts,
-or user activity.")
-    (license (list license:gpl2+ license:lgpl2.1+))))
+           qtbase-5 qtx11extras))))
 
 (define-public kirigami
   ;; Kirigami is listed as tier 1 framework, but optionally includes