diff mbox series

[bug#70395,kde-team,63/63] gnu: Add kded-6.

Message ID 40fe85880973a9e3e26b8ce4d9cc622cf94cf0e4.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:47 p.m. UTC
* gnu/packages/kde-frameworks.scm (kded-6): New variable.
(kded): Inherit above.

Change-Id: Ib35f76394754e778caa165e379fe75d45488da86
---
 gnu/packages/kde-frameworks.scm | 43 ++++++++++++++++++++++++++-------
 1 file changed, 34 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 84222a495d..ee9c63c6cf 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3545,8 +3545,41 @@  (define-public kdeclarative
     ;; dual licensed
     (license (list license:gpl2+ license:lgpl2.1+))))
 
+(define-public kded-6
+  (package
+    (name "kded")
+    (version "6.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "18cv25xyhs5b31mvh3k6vvzm163893ra6nvfjbd1jp4r6vr0x3di"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     (list extra-cmake-modules kdoctools-6))
+    (inputs
+     (list kconfig-6
+           kcoreaddons-6
+           kcrash-6
+           kdbusaddons-6
+           kdoctools-6
+           kservice-6
+           qtbase))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Central daemon of KDE work spaces")
+    (description "KDED stands for KDE Daemon.  KDED runs in the background and
+performs a number of small tasks.  Some of these tasks are built in, others are
+started on demand.")
+    ;; dual licensed
+    (license (list license:lgpl2.0+ license:lgpl2.1+))))
+
 (define-public kded
   (package
+    (inherit kded-6)
     (name "kded")
     (version "5.114.0")
     (source (origin
@@ -3558,7 +3591,6 @@  (define-public kded
               (sha256
                (base32
                 "00n4isc4ahii0ldrg761lkmnq27kmrfqs9zkmpvmgbg57259mvc3"))))
-    (build-system cmake-build-system)
     (native-inputs
      (list extra-cmake-modules kdoctools))
     (inputs
@@ -3568,14 +3600,7 @@  (define-public kded
            kdbusaddons
            kdoctools
            kservice
-           qtbase-5))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "Central daemon of KDE work spaces")
-    (description "KDED stands for KDE Daemon.  KDED runs in the background and
-performs a number of small tasks.  Some of these tasks are built in, others are
-started on demand.")
-    ;; dual licensed
-    (license (list license:lgpl2.0+ license:lgpl2.1+))))
+           qtbase-5))))
 
 (define-public kdesignerplugin
   (package