diff mbox series

[bug#70395,kde-team,29/63] gnu: Add kcolorscheme.

Message ID e3ae07a982dd7f07db03b5642ecf630b6a9a07c2.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:47 p.m. UTC
* gnu/packages/kde-frameworks.scm (kcolorscheme): New variable.

Change-Id: I88ab08e681587f9bce1fc5c29ac0dc1e98efd061
---
 gnu/packages/kde-frameworks.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index be2fd51974..3c0121aef2 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -698,6 +698,36 @@  (define-public kcolorpicker
 which can be used to add custom colors to the popup menu.")
     (license license:lgpl3+)))
 
+(define-public kcolorscheme
+  (package
+    (name "kcolorscheme")
+    (version "6.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+
+              (sha256
+               (base32
+                "0sh3bdy0zpm7w59qbwdyiygs9p1b76001awd0v20fs3079zsh2n3"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list kguiaddons-6 ki18n-6
+                  qtdeclarative))
+    (propagated-inputs (list kconfig-6))
+    (arguments (list #:qtbase qtbase))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Classes to read and interact with KColorScheme")
+    (description "This package provide a Classes to read and interact with
+KColorScheme.")
+    (license (list license:cc0
+                   license:lgpl2.0+
+                   license:lgpl2.1
+                   license:bsd-2
+                   license:lgpl3))))
+
 (define-public kconfig-6
   (package
     (name "kconfig")