diff mbox series

[bug#70395,kde-team,04/63] gnu: Add kcodecs-6.

Message ID bfcbbd307364a9ddd79271b1d6c56469098dc0e5.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Z572 April 15, 2024, 12:46 p.m. UTC
* gnu/packages/kde-frameworks.scm (kcodecs-6): New variable.
(kcodecs): Inherit above.

Change-Id: I2a3dc714ba3a0756808152318639ad20512a7bc1
---
 gnu/packages/kde-frameworks.scm | 27 ++++++++++++++++++++++-----
 1 file changed, 22 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 235c07e5f7..3338924775 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -565,10 +565,10 @@  (define-public kcalendarcore
 and the older vCalendar.")
     (license (list license:lgpl3+ license:bsd-2))))
 
-(define-public kcodecs
+(define-public kcodecs-6
   (package
     (name "kcodecs")
-    (version "5.114.0")
+    (version "6.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -577,10 +577,10 @@  (define-public kcodecs
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "080zvcqd8iq05p5x3qaf3rryx75lg2l2j1dr18sp50ir50zfwh2w"))))
+                "05iqhjyrrbjk0qiwpwpkkyhf1yd19s29jyazbhxn3pdjamchgw7i"))))
     (build-system cmake-build-system)
-    (native-inputs (list extra-cmake-modules gperf qttools-5))
-    (inputs (list qtbase-5))
+    (native-inputs (list extra-cmake-modules gperf qttools))
+    (inputs (list qtbase))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "String encoding and manipulating library")
     (description "KCodecs provide a collection of methods to manipulate
@@ -597,6 +597,23 @@  (define-public kcodecs
                    license:lgpl2.1 license:lgpl2.1+ license:expat
                    license:lgpl3+ license:mpl1.1))))
 
+(define-public kcodecs
+  (package
+    (inherit kcodecs-6)
+    (name "kcodecs")
+    (version "5.114.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "080zvcqd8iq05p5x3qaf3rryx75lg2l2j1dr18sp50ir50zfwh2w"))))
+    (native-inputs (list extra-cmake-modules gperf qttools-5))
+    (inputs (list qtbase-5))))
+
 (define-public kcolorpicker
   (package
     (name "kcolorpicker")