diff mbox series

[bug#70395,kde-team,53/63] gnu: qtbase: propagate libxkbcommon.

Message ID 02925a68152b02d7c75c3a9b6119184f6112848e.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:47 p.m. UTC
* gnu/packages/qt.scm (qtbase)[propagated-inputs]: prepend libxkbcommon.
[inputs]: Remove libxkbcommon-1.5.

Change-Id: I1bea99e4580242bb6e83cf43129ab49935ef79d3
---
 gnu/packages/qt.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer April 17, 2024, 6:01 p.m. UTC | #1
Hello Zheng,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/qt.scm (qtbase)[propagated-inputs]: prepend libxkbcommon.
> [inputs]: Remove libxkbcommon-1.5.
>
> Change-Id: I1bea99e4580242bb6e83cf43129ab49935ef79d3
> ---
>  gnu/packages/qt.scm | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 13af841455..fa1e016178 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -1083,6 +1083,10 @@ (define-public qtbase
>         (prepend tzdata-for-tests
>                  wayland-protocols
>                  xvfb-run)))
> +    (propagated-inputs
> +     (modify-inputs (package-propagated-inputs qtbase-5)
> +       ;; Qt6::GuiPrivate require XKB::XKB

Could you be more explicit here?  This is a CMake imported target
dependency?  Can't XKB be patched in the CMake files to avoid having to
propagate it?  Propagation is best avoided unless it's not technically
possible to do so.

> +       (prepend libxkbcommon)))
>      (inputs
>       (modify-inputs (package-inputs qtbase-5)
>         (prepend at-spi2-core
> @@ -1095,7 +1099,8 @@ (define-public qtbase
>                  libxcb
>                  libxext
>                  xcb-util-cursor
> -                `(,zstd "lib"))))
> +                `(,zstd "lib"))
> +       (delete "libxkbcommon")))

I've noticed the annoyance of having to add libxkbcommon to seemingly
every Qt 6 package, so I'm happy this will get resolved.
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13af841455..fa1e016178 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1083,6 +1083,10 @@  (define-public qtbase
        (prepend tzdata-for-tests
                 wayland-protocols
                 xvfb-run)))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs qtbase-5)
+       ;; Qt6::GuiPrivate require XKB::XKB
+       (prepend libxkbcommon)))
     (inputs
      (modify-inputs (package-inputs qtbase-5)
        (prepend at-spi2-core
@@ -1095,7 +1099,8 @@  (define-public qtbase
                 libxcb
                 libxext
                 xcb-util-cursor
-                `(,zstd "lib"))))
+                `(,zstd "lib"))
+       (delete "libxkbcommon")))
     (native-search-paths
      (list (search-path-specification
             (variable "QMAKEPATH")