diff mbox series

[bug#70395,kde-team,15/63] gnu: Add kconfig-6.

Message ID a8f8b837a57b62e0177acf09b8fca259caad1b26.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:46 p.m. UTC
* gnu/packages/kde-frameworks.scm (kconfig-6): New variable.
(kconfig): Inherit above.

Change-Id: Ib806189b63ce5f9c47cdf44a5fec810f9e99f347
---
 gnu/packages/kde-frameworks.scm | 74 +++++++++++++++++++++++++--------
 1 file changed, 57 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index f5448b91e8..768c6b8f00 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -640,10 +640,10 @@  (define-public kcolorpicker
 which can be used to add custom colors to the popup menu.")
     (license license:lgpl3+)))
 
-(define-public kconfig
+(define-public kconfig-6
   (package
     (name "kconfig")
-    (version "5.114.0")
+    (version "6.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -652,23 +652,31 @@  (define-public kconfig
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0hghdh4p6cq9ckp4g5jdgd8w47pdsxxvzimrdfjrs71lmy8ydiy2"))))
-    (build-system cmake-build-system)
+                "1xyadln77aa4xn9qh85f5hsvyaf2nm292qiz1ykn0lmcpqjmznig"))))
+    (build-system qt-build-system)
     (native-inputs
-     (list dbus extra-cmake-modules inetutils qttools-5
-           xorg-server-for-tests))
-    (inputs
-     (list qtbase-5 qtdeclarative-5))
+     (list dbus extra-cmake-modules inetutils qttools))
+    (propagated-inputs (list qtdeclarative))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests? ;; kconfigcore-kconfigtest fails inconsistently!!
-               (setenv "HOME" (getcwd))
-               (setenv "QT_QPA_PLATFORM" "offscreen")
-               (invoke "ctest" "-E" "(kconfigcore-kconfigtest|\
-kconfiggui-kstandardshortcutwatchertest)")))))))
+     (list
+      #:qtbase qtbase
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'check-setup
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (with-output-to-file "autotests/BLACKLIST"
+                  (lambda _
+                    (for-each
+                     (lambda (name)
+                       (display (string-append "[" name "]\n*\n")))
+                     (list "testNotifyIllegalObjectPath"
+                           "testLocalDeletion"
+                           "testNotify"
+                           "testSignal"
+                           "testDataUpdated"))))
+                (setenv "HOME" (getcwd))
+                (setenv "QT_QPA_PLATFORM" "offscreen")))))))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Kconfiguration settings framework for Qt")
     (description "KConfig provides an advanced configuration system.
@@ -700,6 +708,38 @@  (define-public kconfig
                    license:lgpl3+ license:gpl1 ; licende:mit-olif
                    license:bsd-2 license:bsd-3))))
 
+(define-public kconfig
+  (package
+    (inherit kconfig-6)
+    (name "kconfig")
+    (version "5.114.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0hghdh4p6cq9ckp4g5jdgd8w47pdsxxvzimrdfjrs71lmy8ydiy2"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     (list dbus extra-cmake-modules inetutils qttools-5
+           xorg-server-for-tests))
+    (inputs
+     (list qtbase-5 qtdeclarative-5))
+    (propagated-inputs '())
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests? ;; kconfigcore-kconfigtest fails inconsistently!!
+                     (setenv "HOME" (getcwd))
+                     (setenv "QT_QPA_PLATFORM" "offscreen")
+                     (invoke "ctest" "-E" "(kconfigcore-kconfigtest|\
+kconfiggui-kstandardshortcutwatchertest)")))))))))
+
 (define-public kcoreaddons-6
   (package
     (name "kcoreaddons")