diff mbox series

[bug#70395,kde-team,44/63] gnu: Add kglobalaccel-6.

Message ID d9ce3859abaff72ce982645734d8becdc74619de.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:47 p.m. UTC
* gnu/packages/kde-frameworks.scm (kglobalaccel-6): New variable.
(kglobalaccel): Inherit above.

Change-Id: I85205691fdac39dca094fbe833abf6eebd4cc36a
---
 gnu/packages/kde-frameworks.scm | 41 ++++++++++++++++++++++++++-------
 1 file changed, 33 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index df167c6095..42d352056f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3450,8 +3450,40 @@  (define-public kemoticons
     ;; dual licensed, image files are licensed under cc-by-sa4.0
     (license (list license:gpl2+ license:lgpl2.1+ license:cc-by-sa4.0))))
 
+(define-public kglobalaccel-6
+  (package
+    (name "kglobalaccel")
+    (version "6.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1wk45z9r6387p54sgqmqyddsni30hbiqihlxb22ybswfi39i6nw8"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list extra-cmake-modules pkg-config qttools))
+    (inputs
+     (list kconfig-6
+           kcrash-6
+           kcoreaddons-6
+           kdbusaddons-6
+           kwindowsystem-6
+           qtdeclarative))
+    (arguments (list #:qtbase qtbase))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Global desktop keyboard shortcuts")
+    (description "KGlobalAccel allows you to have global accelerators that are
+independent of the focused window.  Unlike regular shortcuts, the application's
+window does not need focus for them to be activated.")
+    (license license:lgpl2.1+)))
+
 (define-public kglobalaccel
   (package
+    (inherit kglobalaccel-6)
     (name "kglobalaccel")
     (version "5.114.0")
     (source (origin
@@ -3463,7 +3495,6 @@  (define-public kglobalaccel
               (sha256
                (base32
                 "19mmav055fnzyl760fyhf0pdvaidd5i1h04l2hcnpin4p1jnpfap"))))
-    (build-system qt-build-system)
     (native-inputs
      (list extra-cmake-modules pkg-config qttools-5))
     (inputs
@@ -3472,16 +3503,10 @@  (define-public kglobalaccel
            kcoreaddons
            kdbusaddons
            kwindowsystem
-           qtbase-5
            qtx11extras
            qtdeclarative-5
            xcb-util-keysyms))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "Global desktop keyboard shortcuts")
-    (description "KGlobalAccel allows you to have global accelerators that are
-independent of the focused window.  Unlike regular shortcuts, the application's
-window does not need focus for them to be activated.")
-    (license license:lgpl2.1+)))
+    (arguments '())))
 
 (define-public kiconthemes
   (package