diff mbox series

[bug#70395,kde-team,33/63] gnu: Add knotifications-6.

Message ID 56e2b90a8c05b65b3fb89c81635496004f045989.1713184499.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series some kde patch. | expand

Commit Message

Zheng Junjie April 15, 2024, 12:47 p.m. UTC
* gnu/packages/kde-frameworks.scm (knotifications-6): New variable.
(knotifications): Inherit above.

Change-Id: Ic4ab3e86754095f8746e835f71e1a586c2d3b882
---
 gnu/packages/kde-frameworks.scm | 38 +++++++++++++++++++++++++++------
 1 file changed, 31 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 2fa6084bec..5801e14a06 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2663,8 +2663,37 @@  (define-public kjobwidgets
 asynchronous jobs.")
     (license license:lgpl2.1+)))
 
+(define-public knotifications-6
+  (package
+    (name "knotifications")
+    (version "6.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1azwmj47735cz5lrvbba7hq7iv3w0d7a60q23d70klfjq55nzwq2"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     (list extra-cmake-modules pkg-config qttools))
+    (propagated-inputs (list qtdeclarative))
+    (inputs
+     (list kconfig-6
+           kcoreaddons-6
+           libcanberra
+           qtbase))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Desktop notifications")
+    (description "KNotification is used to notify the user of an event.  It
+covers feedback and persistent events.")
+    (license license:lgpl2.1+)))
+
 (define-public knotifications
   (package
+    (inherit knotifications-6)
     (name "knotifications")
     (version "5.114.0")
     (source (origin
@@ -2676,7 +2705,6 @@  (define-public knotifications
               (sha256
                (base32
                 "0cjd5ml9hyzprjgmrc132cmp7g9hnl0h5swlxw2ifqnxxyfkg72b"))))
-    (build-system cmake-build-system)
     (native-inputs
      (list extra-cmake-modules dbus pkg-config qttools-5))
     (inputs
@@ -2691,6 +2719,7 @@  (define-public knotifications
            qtbase-5
            qtspeech-5
            qtx11extras))
+    (propagated-inputs '())
     (arguments
      (list #:phases #~(modify-phases %standard-phases
                         (replace 'check
@@ -2699,12 +2728,7 @@  (define-public knotifications
                               (setenv "HOME"
                                       (getcwd))
                               (setenv "DBUS_FATAL_WARNINGS" "0")
-                              (invoke "dbus-launch" "ctest")))))))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "Desktop notifications")
-    (description "KNotification is used to notify the user of an event.  It
-covers feedback and persistent events.")
-    (license license:lgpl2.1+)))
+                              (invoke "dbus-launch" "ctest")))))))))
 
 (define-public kpackage
   (package