diff mbox series

[bug#48575,23/50] gnu: r-keggrest: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-23-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-keggrest): Move from here...
* gnu/packages/bioconductor.scm (r-keggrest): ...to here.
---
 gnu/packages/bioconductor.scm   | 26 ++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 26 --------------------------
 2 files changed, 26 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6d60b5884c..5ee670e858 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2634,6 +2634,32 @@  microarray data, using nearest neighbor averaging.")
 Shiny-based display methods for Bioconductor objects.")
     (license license:artistic2.0)))
 
+(define-public r-keggrest
+  (package
+    (name "r-keggrest")
+    (version "1.30.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "KEGGREST" version))
+       (sha256
+        (base32
+         "0k9z85xf9la2y98xqmdmjb8mci9fh2fdybkl77x1yl26hyalip0s"))))
+    (properties `((upstream-name . "KEGGREST")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biostrings" ,r-biostrings)
+       ("r-httr" ,r-httr)
+       ("r-png" ,r-png)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/KEGGREST")
+    (synopsis "Client-side REST access to KEGG")
+    (description
+     "This package provides a package that provides a client interface to the
+@dfn{Kyoto Encyclopedia of Genes and Genomes} (KEGG) REST server.")
+    (license license:artistic2.0)))
+
 (define-public r-limma
   (package
     (name "r-limma")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b789ecd977..5dacf8a342 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8994,32 +8994,6 @@  their variance is independent of the mean, and they are usually more sensitive
 and specific in detecting differential transcription.")
     (license license:artistic2.0)))
 
-(define-public r-keggrest
-  (package
-    (name "r-keggrest")
-    (version "1.30.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "KEGGREST" version))
-       (sha256
-        (base32
-         "0k9z85xf9la2y98xqmdmjb8mci9fh2fdybkl77x1yl26hyalip0s"))))
-    (properties `((upstream-name . "KEGGREST")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biostrings" ,r-biostrings)
-       ("r-httr" ,r-httr)
-       ("r-png" ,r-png)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr)))
-    (home-page "https://bioconductor.org/packages/KEGGREST")
-    (synopsis "Client-side REST access to KEGG")
-    (description
-     "This package provides a package that provides a client interface to the
-@dfn{Kyoto Encyclopedia of Genes and Genomes} (KEGG) REST server.")
-    (license license:artistic2.0)))
-
 (define-public r-gage
   (package
     (name "r-gage")