diff mbox series

[bug#48575,39/50] gnu: r-rhtslib: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-39-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:26 p.m. UTC
* gnu/packages/bioinformatics.scm (r-rhtslib): Move from here...
* gnu/packages/bioconductor.scm (r-rhtslib): ...to here.
---
 gnu/packages/bioconductor.scm   | 32 ++++++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 31 -------------------------------
 2 files changed, 32 insertions(+), 31 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e720d7bf6a..8e78a2a0ca 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -39,6 +39,7 @@ 
   #:use-module (gnu packages boost)
   #:use-module (gnu packages cran)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages graph)
   #:use-module (gnu packages graphviz)
@@ -2832,6 +2833,37 @@  Enrichment Analysis} (GSEA).")
 the Human Protein Atlas project.")
     (license license:artistic2.0)))
 
+(define-public r-rhtslib
+  (package
+    (name "r-rhtslib")
+    (version "1.22.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "Rhtslib" version))
+       (sha256
+        (base32
+         "18wag2jnpda6078xjkpfdvar1gkb2myhw83gg03l39sabh35qya4"))))
+    (properties `((upstream-name . "Rhtslib")))
+    (build-system r-build-system)
+    ;; Without this a temporary directory ends up in the Rhtslib.so binary,
+    ;; which makes R abort the build.
+    (arguments '(#:configure-flags '("--no-staged-install")))
+    (propagated-inputs
+     `(("curl" ,curl)
+       ("zlib" ,zlib) ; packages using rhtslib need to link with zlib
+       ("r-zlibbioc" ,r-zlibbioc)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/nhayden/Rhtslib")
+    (synopsis "High-throughput sequencing library as an R package")
+    (description
+     "This package provides the HTSlib C library for high-throughput
+nucleotide sequence analysis.  The package is primarily useful to developers
+of other R packages who wish to make use of HTSlib.")
+    (license license:lgpl2.0+)))
+
 (define-public r-impute
   (package
     (name "r-impute")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 39c437f4a2..586efcf21e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7872,37 +7872,6 @@  including VCF header and contents in RDF and JSON.")
 secondary structure and comparative analysis in R.")
     (license license:gpl3+)))
 
-(define-public r-rhtslib
-  (package
-    (name "r-rhtslib")
-    (version "1.22.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "Rhtslib" version))
-       (sha256
-        (base32
-         "18wag2jnpda6078xjkpfdvar1gkb2myhw83gg03l39sabh35qya4"))))
-    (properties `((upstream-name . "Rhtslib")))
-    (build-system r-build-system)
-    ;; Without this a temporary directory ends up in the Rhtslib.so binary,
-    ;; which makes R abort the build.
-    (arguments '(#:configure-flags '("--no-staged-install")))
-    (propagated-inputs
-     `(("curl" ,curl)
-       ("zlib" ,zlib) ; packages using rhtslib need to link with zlib
-       ("r-zlibbioc" ,r-zlibbioc)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("r-knitr" ,r-knitr)))
-    (home-page "https://github.com/nhayden/Rhtslib")
-    (synopsis "High-throughput sequencing library as an R package")
-    (description
-     "This package provides the HTSlib C library for high-throughput
-nucleotide sequence analysis.  The package is primarily useful to developers
-of other R packages who wish to make use of HTSlib.")
-    (license license:lgpl2.0+)))
-
 (define-public r-bamsignals
   (package
     (name "r-bamsignals")