diff mbox series

[bug#48575,30/50] gnu: r-vsn: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-30-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:26 p.m. UTC
* gnu/packages/bioinformatics.scm (r-vsn): Move from here...
* gnu/packages/bioconductor.scm (r-vsn): ...to here.
---
 gnu/packages/bioconductor.scm   | 36 +++++++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 36 ---------------------------------
 2 files changed, 36 insertions(+), 36 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d0ebcf8481..05c4896276 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3480,6 +3480,42 @@  dependencies between GO terms can be implemented and applied.")
 coding changes and predict coding outcomes.")
     (license license:artistic2.0)))
 
+(define-public r-vsn
+  (package
+    (name "r-vsn")
+    (version "3.58.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "vsn" version))
+       (sha256
+        (base32
+         "0dfrfflidpnphwyqzmmfiz9blfqv6qa09xlwgfabhpfsf3ml2rlb"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-affy" ,r-affy)
+       ("r-biobase" ,r-biobase)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-lattice" ,r-lattice)
+       ("r-limma" ,r-limma)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr))) ; for vignettes
+    (home-page "https://bioconductor.org/packages/release/bioc/html/vsn.html")
+    (synopsis "Variance stabilization and calibration for microarray data")
+    (description
+     "The package implements a method for normalising microarray intensities,
+and works for single- and multiple-color arrays.  It can also be used for data
+from other technologies, as long as they have similar format.  The method uses
+a robust variant of the maximum-likelihood estimator for an
+additive-multiplicative error model and affine calibration.  The model
+incorporates data calibration step (a.k.a.  normalization), a model for the
+dependence of the variance on the mean intensity and a variance stabilizing
+data transformation.  Differences between transformed intensities are
+analogous to \"normalized log-ratios\".  However, in contrast to the latter,
+their variance is independent of the mean, and they are usually more sensitive
+and specific in detecting differential transcription.")
+    (license license:artistic2.0)))
+
 (define-public r-xvector
   (package
     (name "r-xvector")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7256df3f83..600c2ca81e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8934,42 +8934,6 @@  proteowizard library for mzML and mzIdentML.  The netCDF reading code has
 previously been used in XCMS.")
     (license license:artistic2.0)))
 
-(define-public r-vsn
-  (package
-    (name "r-vsn")
-    (version "3.58.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "vsn" version))
-       (sha256
-        (base32
-         "0dfrfflidpnphwyqzmmfiz9blfqv6qa09xlwgfabhpfsf3ml2rlb"))))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-affy" ,r-affy)
-       ("r-biobase" ,r-biobase)
-       ("r-ggplot2" ,r-ggplot2)
-       ("r-lattice" ,r-lattice)
-       ("r-limma" ,r-limma)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr))) ; for vignettes
-    (home-page "https://bioconductor.org/packages/release/bioc/html/vsn.html")
-    (synopsis "Variance stabilization and calibration for microarray data")
-    (description
-     "The package implements a method for normalising microarray intensities,
-and works for single- and multiple-color arrays.  It can also be used for data
-from other technologies, as long as they have similar format.  The method uses
-a robust variant of the maximum-likelihood estimator for an
-additive-multiplicative error model and affine calibration.  The model
-incorporates data calibration step (a.k.a.  normalization), a model for the
-dependence of the variance on the mean intensity and a variance stabilizing
-data transformation.  Differences between transformed intensities are
-analogous to \"normalized log-ratios\".  However, in contrast to the latter,
-their variance is independent of the mean, and they are usually more sensitive
-and specific in detecting differential transcription.")
-    (license license:artistic2.0)))
-
 (define-public r-ensembldb
   (package
     (name "r-ensembldb")