diff mbox series

[bug#48575,25/50] gnu: r-complexheatmap: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-25-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-complexheatmap): Move from here...
* gnu/packages/bioconductor.scm (r-complexheatmap): ...to here.
---
 gnu/packages/bioconductor.scm   | 39 +++++++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 39 ---------------------------------
 2 files changed, 39 insertions(+), 39 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f6d3ef897a..92eb5a0906 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2082,6 +2082,45 @@  genome data packages and support for efficient SNP representation.")
 analysis.")
     (license license:artistic2.0)))
 
+(define-public r-complexheatmap
+  (package
+    (name "r-complexheatmap")
+    (version "2.6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ComplexHeatmap" version))
+       (sha256
+        (base32
+         "1nx1xxpq8zrvi990v9fmvx3msl85pdz5dp1gp6m78q6i4s2alg5x"))))
+    (properties
+     `((upstream-name . "ComplexHeatmap")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-cairo" ,r-cairo)
+       ("r-circlize" ,r-circlize)
+       ("r-clue" ,r-clue)
+       ("r-colorspace" ,r-colorspace)
+       ("r-digest" ,r-digest)
+       ("r-getoptlong" ,r-getoptlong)
+       ("r-globaloptions" ,r-globaloptions)
+       ("r-iranges" ,r-iranges)
+       ("r-matrixstats" ,r-matrixstats)
+       ("r-png" ,r-png)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-s4vectors" ,r-s4vectors)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page
+     "https://github.com/jokergoo/ComplexHeatmap")
+    (synopsis "Making Complex Heatmaps")
+    (description
+     "Complex heatmaps are efficient to visualize associations between
+different sources of data sets and reveal potential structures.  This package
+provides a highly flexible way to arrange multiple heatmaps and supports
+self-defined annotation graphics.")
+    (license license:gpl2+)))
+
 (define-public r-deseq
   (package
     (name "r-deseq")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index daf1fb6958..acaf41acc4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9028,45 +9028,6 @@  distributed by file or by range.  User defined mapper and reducer functions
 provide added flexibility for data combination and manipulation.")
     (license license:artistic2.0)))
 
-(define-public r-complexheatmap
-  (package
-    (name "r-complexheatmap")
-    (version "2.6.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "ComplexHeatmap" version))
-       (sha256
-        (base32
-         "1nx1xxpq8zrvi990v9fmvx3msl85pdz5dp1gp6m78q6i4s2alg5x"))))
-    (properties
-     `((upstream-name . "ComplexHeatmap")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-cairo" ,r-cairo)
-       ("r-circlize" ,r-circlize)
-       ("r-clue" ,r-clue)
-       ("r-colorspace" ,r-colorspace)
-       ("r-digest" ,r-digest)
-       ("r-getoptlong" ,r-getoptlong)
-       ("r-globaloptions" ,r-globaloptions)
-       ("r-iranges" ,r-iranges)
-       ("r-matrixstats" ,r-matrixstats)
-       ("r-png" ,r-png)
-       ("r-rcolorbrewer" ,r-rcolorbrewer)
-       ("r-s4vectors" ,r-s4vectors)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr)))
-    (home-page
-     "https://github.com/jokergoo/ComplexHeatmap")
-    (synopsis "Making Complex Heatmaps")
-    (description
-     "Complex heatmaps are efficient to visualize associations between
-different sources of data sets and reveal potential structures.  This package
-provides a highly flexible way to arrange multiple heatmaps and supports
-self-defined annotation graphics.")
-    (license license:gpl2+)))
-
 (define-public r-dirichletmultinomial
   (package
     (name "r-dirichletmultinomial")