diff mbox series

[bug#48575,04/50] gnu: r-topgo: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-4-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-topgo): Move from here...
* gnu/packages/bioconductor.scm (r-topgo): ...to here.
---
 gnu/packages/bioconductor.scm   | 33 +++++++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 33 ---------------------------------
 2 files changed, 33 insertions(+), 33 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2263c17cc4..2afb5214ee 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2607,6 +2607,39 @@  experimental designs is facilitated by a consistently implemented sample
 annotation infrastructure.")
     (license license:artistic2.0)))
 
+(define-public r-topgo
+  (package
+    (name "r-topgo")
+    (version "2.42.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "topGO" version))
+              (sha256
+               (base32
+                "0vr3l9gvd3dhy446k3fkj6rm7z1abxi56rbnrs64297yzxaz1ngl"))))
+    (properties
+     `((upstream-name . "topGO")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)
+       ("r-dbi" ,r-dbi)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-go-db" ,r-go-db)
+       ("r-graph" ,r-graph)
+       ("r-lattice" ,r-lattice)
+       ("r-matrixstats" ,r-matrixstats)
+       ("r-sparsem" ,r-sparsem)))
+    (home-page "https://bioconductor.org/packages/topGO")
+    (synopsis "Enrichment analysis for gene ontology")
+    (description
+     "The topGO package provides tools for testing @dfn{gene ontology} (GO)
+terms while accounting for the topology of the GO graph.  Different test
+statistics and different methods for eliminating local similarities and
+dependencies between GO terms can be implemented and applied.")
+    ;; Any version of the LGPL applies.
+    (license license:lgpl2.1+)))
+
 (define-public r-variantannotation
   (package
     (name "r-variantannotation")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bf8cb2f3a5..32d2b6a683 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7873,39 +7873,6 @@  including VCF header and contents in RDF and JSON.")
 information about the latest version of the Gene Ontologies.")
     (license license:artistic2.0)))
 
-(define-public r-topgo
-  (package
-    (name "r-topgo")
-    (version "2.42.0")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "topGO" version))
-              (sha256
-               (base32
-                "0vr3l9gvd3dhy446k3fkj6rm7z1abxi56rbnrs64297yzxaz1ngl"))))
-    (properties
-     `((upstream-name . "topGO")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-annotationdbi" ,r-annotationdbi)
-       ("r-dbi" ,r-dbi)
-       ("r-biobase" ,r-biobase)
-       ("r-biocgenerics" ,r-biocgenerics)
-       ("r-go-db" ,r-go-db)
-       ("r-graph" ,r-graph)
-       ("r-lattice" ,r-lattice)
-       ("r-matrixstats" ,r-matrixstats)
-       ("r-sparsem" ,r-sparsem)))
-    (home-page "https://bioconductor.org/packages/topGO")
-    (synopsis "Enrichment analysis for gene ontology")
-    (description
-     "The topGO package provides tools for testing @dfn{gene ontology} (GO)
-terms while accounting for the topology of the GO graph.  Different test
-statistics and different methods for eliminating local similarities and
-dependencies between GO terms can be implemented and applied.")
-    ;; Any version of the LGPL applies.
-    (license license:lgpl2.1+)))
-
 (define-public r-bsgenome
   (package
     (name "r-bsgenome")