diff mbox series

[bug#48575,34/50] gnu: r-protgenerics: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-34-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:26 p.m. UTC
* gnu/packages/bioinformatics.scm (r-protgenerics): Move from here...
* gnu/packages/bioconductor.scm (r-protgenerics): ...to here.
---
 gnu/packages/bioconductor.scm   | 20 ++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 20 --------------------
 2 files changed, 20 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 5ceffd7b4d..a9365a4018 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3175,6 +3175,26 @@  the results is also provided.  All PCA methods make use of the same data
 structure (pcaRes) to provide a common interface to the PCA results.")
     (license license:gpl3+)))
 
+(define-public r-protgenerics
+  (package
+    (name "r-protgenerics")
+    (version "1.22.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ProtGenerics" version))
+       (sha256
+        (base32
+         "0yihxphgkshvfv1sn67wc4zvr2zlzws2j7ki3zabm6vyfkfdkfiz"))))
+    (properties `((upstream-name . "ProtGenerics")))
+    (build-system r-build-system)
+    (home-page "https://github.com/lgatto/ProtGenerics")
+    (synopsis "S4 generic functions for proteomics infrastructure")
+    (description
+     "This package provides S4 generic functions needed by Bioconductor
+proteomics packages.")
+    (license license:artistic2.0)))
+
 (define-public r-rbgl
   (package
     (name "r-rbgl")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a6321a179a..6120cb6804 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8853,26 +8853,6 @@  for analyzing gene-level association tests in meta-analyses for binary
 trait.")
     (license license:gpl3)))
 
-(define-public r-protgenerics
-  (package
-    (name "r-protgenerics")
-    (version "1.22.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "ProtGenerics" version))
-       (sha256
-        (base32
-         "0yihxphgkshvfv1sn67wc4zvr2zlzws2j7ki3zabm6vyfkfdkfiz"))))
-    (properties `((upstream-name . "ProtGenerics")))
-    (build-system r-build-system)
-    (home-page "https://github.com/lgatto/ProtGenerics")
-    (synopsis "S4 generic functions for proteomics infrastructure")
-    (description
-     "This package provides S4 generic functions needed by Bioconductor
-proteomics packages.")
-    (license license:artistic2.0)))
-
 (define-public r-dropbead
   (let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
         (revision "2"))