diff mbox series

[bug#48575,21/50] gnu: r-fastseg: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-21-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-fastseg): Move from here...
* gnu/packages/bioconductor.scm (r-fastseg): ...to here.
---
 gnu/packages/bioconductor.scm   | 30 ++++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 30 ------------------------------
 2 files changed, 30 insertions(+), 30 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4657b0fa8b..313ed7e36f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2236,6 +2236,36 @@  other types of genomic data that produce counts, including ChIP-seq, SAGE and
 CAGE.")
     (license license:gpl2+)))
 
+(define-public r-fastseg
+  (package
+    (name "r-fastseg")
+    (version "1.36.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "fastseg" version))
+       (sha256
+        (base32
+         "1ln6w93ag4wanp0nrm0pqngbfc88w95zq2kcj583hbxy885dkg4f"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-iranges" ,r-iranges)
+       ("r-s4vectors" ,r-s4vectors)))
+    (home-page "https://www.bioinf.jku.at/software/fastseg/index.html")
+    (synopsis "Fast segmentation algorithm for genetic sequencing data")
+    (description
+     "Fastseg implements a very fast and efficient segmentation algorithm.
+It can segment data from DNA microarrays and data from next generation
+sequencing for example to detect copy number segments.  Further it can segment
+data from RNA microarrays like tiling arrays to identify transcripts.  Most
+generally, it can segment data given as a matrix or as a vector.  Various data
+formats can be used as input to fastseg like expression set objects for
+microarrays or GRanges for sequencing data.")
+    (license license:lgpl2.0+)))
+
 (define-public r-genefilter
   (package
     (name "r-genefilter")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1dc2d6f977..33680c283d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9022,36 +9022,6 @@  their variance is independent of the mean, and they are usually more sensitive
 and specific in detecting differential transcription.")
     (license license:artistic2.0)))
 
-(define-public r-fastseg
-  (package
-    (name "r-fastseg")
-    (version "1.36.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "fastseg" version))
-       (sha256
-        (base32
-         "1ln6w93ag4wanp0nrm0pqngbfc88w95zq2kcj583hbxy885dkg4f"))))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biobase" ,r-biobase)
-       ("r-biocgenerics" ,r-biocgenerics)
-       ("r-genomicranges" ,r-genomicranges)
-       ("r-iranges" ,r-iranges)
-       ("r-s4vectors" ,r-s4vectors)))
-    (home-page "https://www.bioinf.jku.at/software/fastseg/index.html")
-    (synopsis "Fast segmentation algorithm for genetic sequencing data")
-    (description
-     "Fastseg implements a very fast and efficient segmentation algorithm.
-It can segment data from DNA microarrays and data from next generation
-sequencing for example to detect copy number segments.  Further it can segment
-data from RNA microarrays like tiling arrays to identify transcripts.  Most
-generally, it can segment data given as a matrix or as a vector.  Various data
-formats can be used as input to fastseg like expression set objects for
-microarrays or GRanges for sequencing data.")
-    (license license:lgpl2.0+)))
-
 (define-public r-keggrest
   (package
     (name "r-keggrest")