diff mbox series

[bug#48575,11/50] gnu: r-go-db: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-11-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-go-db): Move from here...
* gnu/packages/bioconductor.scm (r-go-db): ...to here.
[source]: Replace 'string-append' by 'bioconductor-uri' with 'annotation.
---
 gnu/packages/bioconductor.scm   | 22 ++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 24 ------------------------
 2 files changed, 22 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1b1b00cde0..eb73909723 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -413,6 +413,28 @@  in Biostrings objects.")
 ID and species.  It is used by functions in the GenomeInfoDb package.")
     (license license:artistic2.0)))
 
+(define-public r-go-db
+  (package
+    (name "r-go-db")
+    (version "3.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "GO.db" version 'annotation))
+              (sha256
+               (base32
+                "0i3wcf5h3n0dawzc1hy0kv74f06j80c47n4p3g3fmrcxlhi3jpa5"))))
+    (properties
+     `((upstream-name . "GO.db")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)))
+    (home-page "https://bioconductor.org/packages/GO.db")
+    (synopsis "Annotation maps describing the entire Gene Ontology")
+    (description
+     "The purpose of this GO.db annotation package is to provide detailed
+information about the latest version of the Gene Ontologies.")
+    (license license:artistic2.0)))
+
 (define-public r-homo-sapiens
   (package
     (name "r-homo-sapiens")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 71e1481af2..71f07748b6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7849,30 +7849,6 @@  including VCF header and contents in RDF and JSON.")
     (home-page "https://github.com/vcflib/bio-vcf")
     (license license:expat)))
 
-(define-public r-go-db
-  (package
-    (name "r-go-db")
-    (version "3.7.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://www.bioconductor.org/packages/"
-                                  "release/data/annotation/src/contrib/GO.db_"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "0i3wcf5h3n0dawzc1hy0kv74f06j80c47n4p3g3fmrcxlhi3jpa5"))))
-    (properties
-     `((upstream-name . "GO.db")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-annotationdbi" ,r-annotationdbi)))
-    (home-page "https://bioconductor.org/packages/GO.db")
-    (synopsis "Annotation maps describing the entire Gene Ontology")
-    (description
-     "The purpose of this GO.db annotation package is to provide detailed
-information about the latest version of the Gene Ontologies.")
-    (license license:artistic2.0)))
-
 (define-public r-genomation
   (package
     (name "r-genomation")