diff mbox series

[bug#48575,10/50] gnu: r-seqpattern: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-10-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-seqpattern): Move from here...
* gnu/packages/bioconductor.scm (r-seqpattern): ...to here.
---
 gnu/packages/bioconductor.scm   | 27 +++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 27 ---------------------------
 2 files changed, 27 insertions(+), 27 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0b40d70397..1b1b00cde0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2655,6 +2655,33 @@  differential expression analysis, RNAseq data and related problems.")
     ;; Any version of the LGPL
     (license license:lgpl3+)))
 
+(define-public r-seqpattern
+  (package
+    (name "r-seqpattern")
+    (version "1.22.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "seqPattern" version))
+              (sha256
+               (base32
+                "0j68n6fwycxjpl2va5fw7ajb123n758s2pq997d76dysxghmrlzq"))))
+    (properties
+     `((upstream-name . "seqPattern")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biostrings" ,r-biostrings)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-iranges" ,r-iranges)
+       ("r-kernsmooth" ,r-kernsmooth)
+       ("r-plotrix" ,r-plotrix)))
+    (home-page "https://bioconductor.org/packages/seqPattern")
+    (synopsis "Visualising oligonucleotide patterns and motif occurrences")
+    (description
+     "This package provides tools to visualize oligonucleotide patterns and
+sequence motif occurrences across a large set of sequences centred at a common
+reference point and sorted by a user defined feature.")
+    (license license:gpl3+)))
+
 (define-public r-shortread
   (package
     (name "r-shortread")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ef5c1a3323..71e1481af2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7873,33 +7873,6 @@  including VCF header and contents in RDF and JSON.")
 information about the latest version of the Gene Ontologies.")
     (license license:artistic2.0)))
 
-(define-public r-seqpattern
-  (package
-    (name "r-seqpattern")
-    (version "1.22.0")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "seqPattern" version))
-              (sha256
-               (base32
-                "0j68n6fwycxjpl2va5fw7ajb123n758s2pq997d76dysxghmrlzq"))))
-    (properties
-     `((upstream-name . "seqPattern")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biostrings" ,r-biostrings)
-       ("r-genomicranges" ,r-genomicranges)
-       ("r-iranges" ,r-iranges)
-       ("r-kernsmooth" ,r-kernsmooth)
-       ("r-plotrix" ,r-plotrix)))
-    (home-page "https://bioconductor.org/packages/seqPattern")
-    (synopsis "Visualising oligonucleotide patterns and motif occurrences")
-    (description
-     "This package provides tools to visualize oligonucleotide patterns and
-sequence motif occurrences across a large set of sequences centred at a common
-reference point and sorted by a user defined feature.")
-    (license license:gpl3+)))
-
 (define-public r-genomation
   (package
     (name "r-genomation")