diff mbox series

[bug#48575,16/50] gnu: r-aroma-light: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-16-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-aroma-light): Move from here...
* gnu/packages/bioconductor.scm (r-aroma-light): ...to here.
---
 gnu/packages/bioconductor.scm   | 27 +++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 27 ---------------------------
 2 files changed, 27 insertions(+), 27 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 5e0b722e2f..e58cd66fef 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1782,6 +1782,33 @@  annotation data packages using SQLite data storage.")
 databases.  Packages produced are intended to be used with AnnotationDbi.")
     (license license:artistic2.0)))
 
+(define-public r-aroma-light
+  (package
+    (name "r-aroma-light")
+    (version "3.20.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "aroma.light" version))
+       (sha256
+        (base32
+         "0pi37rlfqh24p9wd7l1xb3f7c7938xdscgcc5agp8c9qhajq25a0"))))
+    (properties `((upstream-name . "aroma.light")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrixstats" ,r-matrixstats)
+       ("r-r-methodss3" ,r-r-methodss3)
+       ("r-r-oo" ,r-r-oo)
+       ("r-r-utils" ,r-r-utils)))
+    (home-page "https://github.com/HenrikBengtsson/aroma.light")
+    (synopsis "Methods for normalization and visualization of microarray data")
+    (description
+     "This package provides methods for microarray analysis that take basic
+data types such as matrices and lists of vectors.  These methods can be used
+standalone, be utilized in other packages, or be wrapped up in higher-level
+classes.")
+    (license license:gpl2+)))
+
 (define-public r-biobase
   (package
     (name "r-biobase")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5b6426e17d..c8444eea9f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9022,33 +9022,6 @@  their variance is independent of the mean, and they are usually more sensitive
 and specific in detecting differential transcription.")
     (license license:artistic2.0)))
 
-(define-public r-aroma-light
-  (package
-    (name "r-aroma-light")
-    (version "3.20.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "aroma.light" version))
-       (sha256
-        (base32
-         "0pi37rlfqh24p9wd7l1xb3f7c7938xdscgcc5agp8c9qhajq25a0"))))
-    (properties `((upstream-name . "aroma.light")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-matrixstats" ,r-matrixstats)
-       ("r-r-methodss3" ,r-r-methodss3)
-       ("r-r-oo" ,r-r-oo)
-       ("r-r-utils" ,r-r-utils)))
-    (home-page "https://github.com/HenrikBengtsson/aroma.light")
-    (synopsis "Methods for normalization and visualization of microarray data")
-    (description
-     "This package provides methods for microarray analysis that take basic
-data types such as matrices and lists of vectors.  These methods can be used
-standalone, be utilized in other packages, or be wrapped up in higher-level
-classes.")
-    (license license:gpl2+)))
-
 (define-public r-deseq
   (package
     (name "r-deseq")