diff mbox series

[bug#48575,14/50] gnu: r-pcamethods: Move to (gnu packages bioconductor).

Message ID 20210521202622.26591-14-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 21, 2021, 8:25 p.m. UTC
* gnu/packages/bioinformatics.scm (r-pcamethods): Move from here...
* gnu/packages/bioconductor.scm (r-pcamethods): ...to here.
---
 gnu/packages/bioconductor.scm   | 30 ++++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 30 ------------------------------
 2 files changed, 30 insertions(+), 30 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 22b5a6068e..1533e5b8f9 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2526,6 +2526,36 @@  contains a number of utilities to explore the MS/MS results and assess missed
 and irregular enzymatic cleavages, mass measurement accuracy, etc.")
     (license license:artistic2.0)))
 
+(define-public r-pcamethods
+  (package
+    (name "r-pcamethods")
+    (version "1.82.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "pcaMethods" version))
+       (sha256
+        (base32
+         "04xb4vjky6hq58l30i1iq9rv5gzjdxnidjxpnzg7pvg67vz8pgf0"))))
+    (properties `((upstream-name . "pcaMethods")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-mass" ,r-mass)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/hredestig/pcamethods")
+    (synopsis "Collection of PCA methods")
+    (description
+     "This package provides Bayesian PCA, Probabilistic PCA, Nipals PCA,
+Inverse Non-Linear PCA and the conventional SVD PCA.  A cluster based method
+for missing value estimation is included for comparison.  BPCA, PPCA and
+NipalsPCA may be used to perform PCA on incomplete data as well as for
+accurate missing value estimation.  A set of methods for printing and plotting
+the results is also provided.  All PCA methods make use of the same data
+structure (pcaRes) to provide a common interface to the PCA results.")
+    (license license:gpl3+)))
+
 (define-public r-rbgl
   (package
     (name "r-rbgl")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 87254a9058..a98f3d5d8a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9053,36 +9053,6 @@  mzIdentML files with the drawback of having less pretty output than a vendor
 specific parser.")
     (license license:gpl2+)))
 
-(define-public r-pcamethods
-  (package
-    (name "r-pcamethods")
-    (version "1.82.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "pcaMethods" version))
-       (sha256
-        (base32
-         "04xb4vjky6hq58l30i1iq9rv5gzjdxnidjxpnzg7pvg67vz8pgf0"))))
-    (properties `((upstream-name . "pcaMethods")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biobase" ,r-biobase)
-       ("r-biocgenerics" ,r-biocgenerics)
-       ("r-mass" ,r-mass)
-       ("r-rcpp" ,r-rcpp)))
-    (home-page "https://github.com/hredestig/pcamethods")
-    (synopsis "Collection of PCA methods")
-    (description
-     "This package provides Bayesian PCA, Probabilistic PCA, Nipals PCA,
-Inverse Non-Linear PCA and the conventional SVD PCA.  A cluster based method
-for missing value estimation is included for comparison.  BPCA, PPCA and
-NipalsPCA may be used to perform PCA on incomplete data as well as for
-accurate missing value estimation.  A set of methods for printing and plotting
-the results is also provided.  All PCA methods make use of the same data
-structure (pcaRes) to provide a common interface to the PCA results.")
-    (license license:gpl3+)))
-
 (define-public r-aroma-light
   (package
     (name "r-aroma-light")