diff mbox series

[bug#38423,05/49] gnu: Add ghc-data-checked.

Message ID 20191129113751.82405-5-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-data-checked): New package.
---
 gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 708159adc6..612bd8100f 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13281,3 +13281,27 @@  zero-copy slicing (thereby saving 2 words).  Consequently, the
 memory footprint of a (boxed) 'ShortText' value is 4 words
 (2 words when unboxed) plus the length of the UTF-8 encoded payload.")
     (license license:bsd-3)))
+
+(define-public ghc-data-checked
+  (package
+    (name "ghc-data-checked")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/data-checked/data-checked-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0xjn7iqlsgi51h8gz4x40kc2qb5lwf6nw5kjwgkck1w5gjfd11yw"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/mvv/data-checked")
+    (synopsis
+     "Type-indexed runtime-checked properties")
+    (description
+     "This package provides a (phantom) type-indexed newtype
+evidence-wrapper for values that are checked to satisfy the
+property associated with the type.")
+    (license license:bsd-3)))