diff mbox series

[bug#38423,39/49] gnu: Add ghc-postgresql-libpq.

Message ID 20191129113751.82405-39-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-postgresql-libpq): New variable.
---
 gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index efe751fa88..4ca9ffa5ec 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -42,12 +42,14 @@ 
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages emacs)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages haskell-apps)
+  #:use-module (gnu packages haskell)
   #:use-module (gnu packages haskell-check)
   #:use-module (gnu packages haskell-crypto)
   #:use-module (gnu packages haskell-web)
@@ -8620,6 +8622,33 @@  standard Read class, for better deserialisation of Haskell values from
 Strings.")
     (license license:lgpl2.1)))
 
+(define-public ghc-postgresql-libpq
+  (package
+    (name "ghc-postgresql-libpq")
+    (version "0.9.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/postgresql-libpq/postgresql-libpq-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1y86kysakfcf3zq252yl2llrx3765vxvkdwda4q5ql7ikv3m786f"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("postgresql" ,postgresql)))
+    (home-page
+     "https://github.com/phadej/postgresql-libpq")
+    (synopsis "low-level binding to libpq")
+    (description
+     "This is a binding to libpq: the C application programmer's interface
+to PostgreSQL.  libpq is a set of library functions that allow client
+programs to pass queries to the PostgreSQL backend server and to receive
+the results of these queries.")
+    (license license:bsd-3)))
+
 (define-public ghc-pqueue
   (package
     (name "ghc-pqueue")