diff mbox series

[bug#38423,29/49] gnu: Add ghc-lens-aeson.

Message ID 20191129113751.82405-29-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-lens-aeson): New variable.
---
 gnu/packages/haskell-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 28179eba97..5cba944601 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13803,3 +13803,41 @@  hints for type inference.")
      "concise provides a handful of functions to extend
 what you can do with Control.Lens.Cons.")
     (license license:bsd-3)))
+
+(define-public ghc-lens-aeson
+  (package
+    (name "ghc-lens-aeson")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/lens-aeson/lens-aeson-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1k028ycmhz7mnjlrap88fqix4nmmpyy6b88m16kv77d3r8sz04a3"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-lens" ,ghc-lens)
+       ("ghc-vector" ,ghc-vector)
+       ("ghc-unordered-containers"
+        ,ghc-unordered-containers)
+       ("ghc-attoparsec" ,ghc-attoparsec)
+       ("ghc-aeson" ,ghc-aeson)
+       ("ghc-scientific" ,ghc-scientific)))
+    (native-inputs
+     `(("ghc-doctest" ,ghc-doctest)
+       ("ghc-generic-deriving" ,ghc-generic-deriving)
+       ("ghc-semigroups" ,ghc-semigroups)
+       ("ghc-simple-reflect" ,ghc-simple-reflect)
+       ("cabal-doctest" ,cabal-doctest)))
+    (arguments
+     `(#:cabal-revision
+       ("6"
+        "1pg5v8fnlqw1krgi3d2a03a0zkjjdv5yp5f5z6q4mlb5jldz99a8")))
+    (home-page "http://github.com/lens/lens-aeson/")
+    (synopsis "Law-abiding lenses for aeson")
+    (description "Law-abiding lenses for aeson")
+    (license license:expat)))